Installing the same app multiple times installs it multiple times in the Dashboard causing serious issues to the Dashboard

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: mdabbagh.mozilla, Assigned: dwalkowski)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 581071 [details]
Screenshot

When the user installs an app multiple times, it will get installed multiple times in the Dashboard. If you then uninstall one of the duplicate apps, the Dashboard will become unusable. If you keep the Dashboard open and go to another tab and install a new app, it will be placed over the duplicate app. If you close and re-launch the Dashboard, a new app icon is displayed (see attachments) with no name. This new 'app' is now unusable. The user cannot delete it, cannot launch it and cannot interact with it in an expected manner. 

Steps to Reproduce:
1. Launch Firefox
2. Install the Apps extension - Tried with openwebapps-adb507752d-12_12_2011.xpi from http://people.mozilla.com/~dclarke/openwebapps/Extension/
3. Go to https://apps-preview-dev.allizom.org/en-US/apps/, log-in and install an app
4. Install the same app again
5. Go to myapps.mozillalabs.com - Notice apps shows multiple times
6. Delete one of the duplicate apps

Actual Results:
The Dashboard is now not usable and the user must close and relaunch the Dashboard. 

Expected Results:
Installing the same app multiple times should not install it multiple times in the Dashboard.
(Reporter)

Comment 1

7 years ago
So it seems that you have to have the Dashboard already launched in another tab and install the app multiple times in order to see it multiple times in the Dashboard. If you install the app multiple times and then launch the Dashboard, the app will only be installed once.
That sounds like an error with how the dashboard is using watchUpdates
Dan believes this can be fixed on the server side.
Assignee: nobody → dwalkowski
Priority: -- → P1
Yes, this bug is in a file that is deployed to myapps, not something embedded in the addon.
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 710180
Deployed on myapps
(Assignee)

Comment 8

7 years ago
r+ anant
(Reporter)

Comment 9

7 years ago
Tested on Firefox 9b5 with openwebapps-325550d8ca-12_13_2011.xpi from http://people.mozilla.com/~dclarke/openwebapps/Extension/ and without having the extension installed as well (HTML5 shim). Tried the scenario mentioned in the bug and tried other scenarios (without first launching the Dashboard and trying to install different apps multiple times) and only one app is installed now. I verified that the apps can be interacted with in the Dashboard as well after attempting multiple installs (launching, uninstalling and re-positioning).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.