Last Comment Bug 710268 - sign NSS libraries only when they exist
: sign NSS libraries only when they exist
Status: RESOLVED FIXED
[qa-]
: regression
Product: Toolkit
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Takanori MATSUURA
:
: Gregory Szorc [:gps]
Mentors:
: 736327 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-13 09:48 PST by Takanori MATSUURA
Modified: 2012-06-21 16:52 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Fix (1.85 KB, patch)
2011-12-13 09:54 PST, Takanori MATSUURA
dtownsend: review+
lukasblakk+bugs: approval‑mozilla‑esr10+
Details | Diff | Splinter Review

Description Takanori MATSUURA 2011-12-13 09:48:22 PST
There are two cases that shlibsign is not generated in the build tree:

1. Build with using system NSS
2. Build Firefox on top of Xulrunner

So we need to sign to SOFTOKN and NSSDBM libraries only when shlibsign exists.
Comment 1 Takanori MATSUURA 2011-12-13 09:54:06 PST
Created attachment 581312 [details] [diff] [review]
Fix

Sign SOFTOKN and NSSDBM only when they exist. shlibsign exists if internal NSS is built.
Comment 2 Ed Morley [:emorley] 2011-12-15 02:32:47 PST
In my queue with a few other checkin-neededs that are being sent to try first and then onto inbound :-)
https://tbpl.mozilla.org/?tree=Try&rev=fd440327d5e4
Comment 4 Ed Morley [:emorley] 2011-12-16 06:18:52 PST
https://hg.mozilla.org/mozilla-central/rev/2bea36280f9a
Comment 5 Wolfgang Rosenauer [:wolfiR] 2012-03-04 09:48:26 PST
This is fixing a regression introduced by another bugfix. (sorry, not sure which one)
That bugfix was applied on releases/mozilla-esr10 and therefore the 10.0.3esr sources are not correctly building in above cases. Please apply this one to 10ESR as well.
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2012-03-07 16:58:54 PST
Comment on attachment 581312 [details] [diff] [review]
Fix

please go ahead and land this to esr branch - see https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for details
Comment 7 Lukas Blakk [:lsblakk] use ?needinfo 2012-03-16 13:18:54 PDT
[Triage Comment]
untracking since this isn't part of our builds, you can land this to esr branch when you need to, if you still want it - since it is of no risk to the builds.
Comment 8 Wolfgang Rosenauer [:wolfiR] 2012-03-16 15:00:10 PDT
https://hg.mozilla.org/releases/mozilla-esr10/rev/b70216a1859d
Comment 9 Mark Banner (:standard8, limited time in Dec) 2012-03-19 03:15:47 PDT
*** Bug 736327 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.