null pointer when attaching android idle handler

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: blassey, Assigned: blassey)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

E/GeckoApp(19132): Exception handling message "Gecko:Ready":
E/GeckoApp(19132): java.lang.NullPointerException
E/GeckoApp(19132): 	at android.os.Looper.myQueue(Looper.java:178)
E/GeckoApp(19132): 	at org.mozilla.gecko.GeckoApp.handleMessage(GeckoApp.java:905)
E/GeckoApp(19132): 	at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:1502)
E/GeckoApp(19132): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
E/GeckoApp(19132): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
E/GeckoApp(19132): 	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:448)
E/GeckoApp(19132): 	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:107)
Created attachment 581391 [details] [diff] [review]
patch
Assignee: nobody → blassey.bugs
Attachment #581391 - Flags: review?(mark.finkle)
Attachment #581391 - Flags: review?(mark.finkle) → review+
pushed https://hg.mozilla.org/mozilla-central/rev/b0165c0d85e1
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
just an fyi, this got backed out along with bug 708280. Since bug 708280 is what caused this regression, this doesn't need need to be reopened

https://hg.mozilla.org/mozilla-central/rev/15a7bbbb9323
You need to log in before you can comment on or make changes to this bug.