Java applet viewing incorrectly

VERIFIED WORKSFORME

Status

()

Core
Internationalization
--
major
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: tracy, Assigned: Xiaobin Lu)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
this has been present since this applet opened on the page

goto www.joins.com

the java applet in the middle of the page is not rendering korean characters 
correctly

Comment 1

17 years ago
cc to momoi, do you remember Sun engineer who has other i18n bugs?

Comment 2

17 years ago
xiaobin.lu@eng.sun.com (Xiaobin Lu) is the engineer
assigned currently to Java i18n bugs.

See the following bug for more:

http://bugzilla.mozilla.org/show_bug.cgi?id=59433

Tracy, did you modify the font.properties file
to use Korean font. 
The default font file used under US Windows
is font.properties file which comes with 
JRE 1.3.x. If you run Mozilla under Korean Windows, 
the font prop file referenced will be
font.properties.ko.

Thus to display Korean under US Windows, you need to
modify the default font.properties file to include
a font which has Korean glyphs.
(Reporter)

Comment 3

17 years ago
uhhh....no I didn't do any font.properties file changing

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 59433 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
This should not be duplicate of Bug 59433, which was
a failure on Unix platform to support font aliasing. 
Font aliasing works for Windows and so even if the 
applet is using a legacy font name, modifying font.properties
should solve the problem.
Let me re-open this bug. I'll check this out with the modified font.prop file and
hopefully will resolve it as Worksforme.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

17 years ago
I'm going to re-assing this to Xiaobin Lu.
I confirmed that when font.properties.xx file is
modified to accommodate Korean, it lets 3/7/2001 
Win32 build display some Korean applets. 
But it does not work on the above URL reported by Tracy.
On Win32 build, font aliasing is also working as one of
the applets I looked at uses a legacy font name.

So there is something different about the above web page.
We should investigate why Korean display is failing. 
Assignee: nhotta → xiaobin.lu
Status: REOPENED → NEW
(Assignee)

Comment 7

17 years ago
I will investigate this soon.
(Assignee)

Comment 8

17 years ago
  I believe that the application has some problem in dealing with the 
internationlization applet. Mozilla can shown Korean, Japanese, Chinese fonts 
well. Try this website:
http://myhome.netsgo.com/xboy2
It has an applet which demos the animation of Korean character.

Bug reporter:
   Can I have the source code to see what really happened? If this is the 
problem of application, I would like to mark this bug as INVALID.
(Reporter)

Comment 9

17 years ago
please note the URL http://www.joins.com at which this bug is present.
Do you really want me to post the entire source code for this page here??
(Assignee)

Comment 10

17 years ago
Could you post the applet source code here?
Thanks!
(Reporter)

Comment 11

17 years ago
I'm sorry, I don't know source code well enough to find that applet for you. If 
you'd care to explain what I should be looking for, I'd be glad to learn.
(Assignee)

Comment 12

17 years ago
  Do you have the applet source code which the fonts are not shown correctly?
Because I believe that the source code made some mistakes.

Comment 13

17 years ago
xiaobin, I looked for the source code but could only get
JoinsStock.class file only. Would that help?
(Assignee)

Comment 14

17 years ago
Tracy:
   Thanks! It does not help. However, I am pretty sure there is something is 
wrong with the application. Could you verify on Netscape 4.75 for me to see if 
it works or not?

Comment 15

17 years ago
I am inclined to agree with you, xiaobin.
The Korean applet at http://myhome.netsgo.com/xboy2
displays OK on Comm 4.76 with a proper font.properties file 
for Korean. And Mozilla can also display it. 
But the applet at: http://www.joins.com
does not display on either NS 4.76 or the current Mozilla.

The only other possibility is that the applet there
is doing correctly but there is a bug in Java. But
we will not know for sure unless we get the source code
file.

I think we can write to the webmaster and tell them 
there is a problem and that they should check the source
code and get back to us.
(Assignee)

Comment 16

17 years ago
 Katsuhiko:
     Would you please email the webmaster? Because I can not understand Korean.
Thanks!

Comment 17

17 years ago
I mailed my comment to the webmaster at joins.com requesting
a check on their code and also the source code for the applet.
Waiting for a reply -- will update when I receive a reply msg.
(Assignee)

Comment 18

17 years ago
Since there are no response from the web master. Close this bug and reopen if 
problem report again.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 19

17 years ago
this is still happening.....please clarify why this was marked invalid.

'til then, reopening
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 20

17 years ago
Could someone resend the email to the webmaster or find some other Korean 
applets which can not be viewed correctly while at the same time contains the 
source code?
(Reporter)

Comment 21

17 years ago
We pulled up a windows 2000 korean machine and used IE5 to view the joins.com 
site.  The java applet there worked fine; the scrolling information was readable 
korean text.
(Assignee)

Comment 22

17 years ago
Tracy:
    I think if  you use Korean Win2000 version to see the applet, that is 
purely Korean and if the applet did not write well(I mean 
internationalization), it still can not be viewed correctly in other version of 
Window2000. I am pretty sure the applet did not process well based on the Java 
internationalization principal because we have some applets which written in 
Chinese/Japanese show very well. I am still waiting for the source code of the 
applet. 

Comment 23

17 years ago
Have you heard from the applet vendor?
(Assignee)

Comment 24

17 years ago
No response from applet vendor.

Comment 25

17 years ago
Changed QA contact to teruko@netscape.com.
QA Contact: andreasb → teruko
(Assignee)

Comment 26

17 years ago
   Since I have not heard from the plugin vendor for a long time and the applet 
international fonts works well in Windows systems. Please go to bug 59433 to 
see the workable case. 
   Reopen if we hear from plugin writer.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 27

17 years ago
sounds fair enough :)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 28

17 years ago
d'oh!!  I spoke too soon.  Used latest windows build 2001-04-24-06-trunk to 
check this against the nervous korean text on http://babel/java/   I am seeing 6 
nervous squares and a ?  I'll not reopen this just yet....Xiaobin, please 
confirm. Thanks :)
(Assignee)

Comment 29

17 years ago
  Sure! Currently because of bug 76921, trunk with java was messed up. I will 
come back after that has been resolved.
You need to log in before you can comment on or make changes to this bug.