Last Comment Bug 710511 - Rename ANP DrawingModel to prevent conflict with AsyncDrawingModel
: Rename ANP DrawingModel to prevent conflict with AsyncDrawingModel
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: Bas Schouten (:bas.schouten)
:
Mentors:
Depends on:
Blocks: 651192
  Show dependency treegraph
 
Reported: 2011-12-13 19:10 PST by Bas Schouten (:bas.schouten)
Modified: 2012-02-09 15:49 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Rename DrawingModel to ANPDrawingModel (3.92 KB, patch)
2011-12-13 19:10 PST, Bas Schouten (:bas.schouten)
snorp: review-
Details | Diff | Review
Fixed up version of Bas' patch (5.46 KB, patch)
2012-01-17 11:00 PST, James Willcox (:snorp) (jwillcox@mozilla.com)
blassey.bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description Bas Schouten (:bas.schouten) 2011-12-13 19:10:24 PST
Created attachment 581514 [details] [diff] [review]
Rename DrawingModel to ANPDrawingModel

We're adding NPAPI async drawing code in a cross-platform manner in bug 651192. Recently we landed code that makes an android specific internal 'DrawingModel', that isn't based on the NPDrawingModel enumeration. We should rename this to not conflict with the new things we're adding based on the existing NPDrawingModel enum.

This patch I have is untested for lack of a current Android build env.
Comment 1 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-01-17 11:00:18 PST
Created attachment 589241 [details] [diff] [review]
Fixed up version of Bas' patch
Comment 2 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-01-17 11:01:52 PST
Comment on attachment 581514 [details] [diff] [review]
Rename DrawingModel to ANPDrawingModel

You need nsNPAPIPluginInstance::GetANPDrawingModel() since nsPluginInstanceOwner::Paint() currently using GetDrawingModel() to get the ANP drawing model. Fixed and tested patch attached.
Comment 3 Bas Schouten (:bas.schouten) 2012-01-17 15:02:52 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/e3ac624ee524
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 17:16:49 PST
Comment on attachment 589241 [details] [diff] [review]
Fixed up version of Bas' patch

[Triage Comment]
approval for beta to keep from having to rebase the rest of snorp's patches
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 19:31:37 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/10045c267ca1

Note You need to log in before you can comment on or make changes to this bug.