Created attachment 581514 [details] [diff] [review] Rename DrawingModel to ANPDrawingModel We're adding NPAPI async drawing code in a cross-platform manner in bug 651192. Recently we landed code that makes an android specific internal 'DrawingModel', that isn't based on the NPDrawingModel enumeration. We should rename this to not conflict with the new things we're adding based on the existing NPDrawingModel enum. This patch I have is untested for lack of a current Android build env.
Comment on attachment 581514 [details] [diff] [review] Rename DrawingModel to ANPDrawingModel You need nsNPAPIPluginInstance::GetANPDrawingModel() since nsPluginInstanceOwner::Paint() currently using GetDrawingModel() to get the ANP drawing model. Fixed and tested patch attached.
Comment on attachment 589241 [details] [diff] [review] Fixed up version of Bas' patch [Triage Comment] approval for beta to keep from having to rebase the rest of snorp's patches