Thunderbird composer does not properly honour html fonts set as default

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 250539
6 years ago
6 years ago

People

(Reporter: Mike Cloaked, Unassigned)

Tracking

9 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7

Steps to reproduce:

I have an html signature in DejaVu Sans font. I specify in Edit->Preferences->Composition->HTML font DejaVu Sans. I compose a new email. With the cursor at the start of the main text box the font is initially and correctly DejaVu. Using right arrow move the cursor which then hits the left of the first dash of the autoentered double dash of the signature - and the font becomes "variable width".  However move the cursor left with the left arrow and the cursor moves back to the start of the main text box - but incorrectly remains "variable width" instead of returning to "DejaVu"

This is for Linux version Mozilla/5.0 (X11; Linux x86_64; rv:9.0) Gecko/20111208 Thunderbird/9.0 ID:20111208092202

The same behaviour was seen for Thunderbird 8 released version.


Actual results:

The font changed to "Variable Width" as soon as the cursor was moved to the start of the signature double dash  (which of course is placed automatically) - but failed to return to DevaVu when the cursor was moved back to the start of the message text area - despite the default font being set into the composer as DejaVu.


Expected results:

The font should have switched back to the correct font when the cursor was moved back into the normal text area when composing a new email.

This behaviour is repeated for replies to email also. The same behaviour occurs for any other font set as the default composition font.

If the font is re-selected as DejaVu for the cursor at the start point, and the cursor moved using right-arrow, then left-arrow the loss of DejaVu to Variable Width font is entirely repeatable. This should be fixed as it is incorrect behaviour.

Comment 1

6 years ago
(In reply to Mike Cloaked from comment #0)
See bug 250539.
(Reporter)

Comment 2

6 years ago
Thanks - will be nice to see this fixed before too long..... clearly a lot of people have been anxious for a resolution -

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.