Support fast conversion of typed arrays to js-ctypes arrays

RESOLVED DUPLICATE of bug 732936

Status

()

Core
js-ctypes
RESOLVED DUPLICATE of bug 732936
6 years ago
6 years ago

People

(Reporter: bholley, Assigned: jdm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
This would be a nice companion to bug 699156, and probably much simpler. We just need to add a special case to ImplicitConvert (after the regular array case) that compares the types and does a direct copy if they match.

I might work on this. We'll see.
(Reporter)

Comment 1

6 years ago
jdm's going to take a crack at this. :-)
Assignee: nobody → josh
Assignee: josh → evilpies
Assignee: evilpies → josh
Bug 732936 doesn't quite fit the title of this bug, but fits the description in comment 1. Plus it has landed :)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732936
You need to log in before you can comment on or make changes to this bug.