address autocomplete interferes with typing

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: fry.kun, Unassigned)

Tracking

8 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111108090109

Steps to reproduce:

Trying to send email to fun@stuff.com:

* Create fresh profile, add an account
* Add 2 contacts to address book: foo@bar.com, foobar@asdf.com
* Open a New Message window
* In the To: box, type in letter f and wait for dropdown to appear
* Type in letter u. It doesn't match anything in the autocomplete list, so the list disappears (okay so far)
* Press backspace to erase letter u. Autocomplete list re-appears
* Press letter u again


Actual results:

First match from autocomplete is filled in, and it's really hard to type in the wanted email address instead of it


Expected results:

Autocomplete menu should've disappeared just like first time
(Reporter)

Updated

7 years ago
Summary: address autocomplete → address autocomplete interferes with typing
(Reporter)

Comment 1

7 years ago
How did this get shipped anyway?!
Severity: normal → critical
Version: unspecified → 8

Comment 2

7 years ago
(In reply to Konstantin Svist from comment #0)
If you type 'f', the list appears, then you type 'u', the list should now disappear and you are able to type fun@stuff.com. I tried this here:
User Agent: Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20111105 Thunderbird/8.0
Build ID: 20111105021619
Can you try to set a longer master password and see if that changes the behavior ?
(Reporter)

Comment 4

7 years ago
(In reply to Hashem Masoud from comment #2)

The bug is activated after you delete the "u" and type it in again.


(In reply to Ludovic Hirlimann [:Usul] from comment #3)

As expected, a longer master password had no effect on the bug. Original bug tried with no master password, this time retried with 20 char ("asdfasdfasdfasdfasdf")
do you have an lldap address book defined?
can you reproduce in safe mode?
 http://support.mozillamessaging.com/en-US/kb/safe-mode
Severity: critical → major
(Reporter)

Comment 6

7 years ago
No lldap, it's a brand new profile as described above. Safe mode makes no difference.
Just replicated the bug on another linux machine (x64).

Please follow original description exactly and you'll see the bug
This works fine for me (yes, on a new profile on 8.0, with the exact email addresses as specified above).
(Reporter)

Comment 8

7 years ago
Just tried to screncap it using a Xephyr window and the bug doesn't show up. Maybe this has to do with using XFCE (as opposed to gnome/kde/none)
(In reply to Konstantin Svist from comment #8)
> Just tried to screncap it using a Xephyr window and the bug doesn't show up.
> Maybe this has to do with using XFCE (as opposed to gnome/kde/none)

Are you saying bug is INVALID?  (not caused by thunderbird?)
please reopen if you disagree
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.