Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Build failure: nsGSettingsService.cpp:298:36: error: ‘G_VARIANT_TYPE_STRING_ARRAY’ was not declared in this scope

RESOLVED FIXED in Firefox 12

Status

()

Firefox
Shell Integration
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Joseph Felps, Assigned: glandium)

Tracking

({regression})

Trunk
Firefox 12
x86_64
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox11- affected)

Details

(Whiteboard: [inbound])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20100101 Firefox/11.0a1
Build ID: 20111130105716

Steps to reproduce:

I get build failure with trunk on Linux x86_64: 

/home/user/mozilla-central/toolkit/system/gnome/nsGSettingsService.cpp: In member function ‘virtual nsresult nsGSettingsCollection::GetStringList(const nsACString&, nsIArray**)’:
/home/user/mozilla-central/toolkit/system/gnome/nsGSettingsService.cpp:298:36: error: ‘G_VARIANT_TYPE_STRING_ARRAY’ was not declared in this scope
make[6]: *** [nsGSettingsService.i_o] Error 1
make[6]: *** Waiting for unfinished jobs....
/home/user/mozilla-central/toolkit/system/gnome/nsGIOService.cpp: In member function ‘virtual nsresult nsGIOMimeApp::GetCommand(nsACString&)’:
/home/user/mozilla-central/toolkit/system/gnome/nsGIOService.cpp:115:70: warning: ISO C++ forbids casting between pointer-to-function and pointer-to-object
make[6]: Leaving directory `/home/user/firefox-build/toolkit/system/gnome'
make[5]: *** [libs_tier_platform] Error 2
make[5]: Leaving directory `/home/user/firefox-build'
make[4]: *** [tier_platform] Error 2
make[4]: Leaving directory `/home/user/firefox-build'
make[3]: *** [default] Error 2
make[3]: Leaving directory `/home/user/firefox-build'
make[2]: *** [realbuild] Error 2
make[2]: Leaving directory `/home/user/mozilla-central'
make[1]: *** [profiledbuild] Error 2
make[1]: Leaving directory `/home/user/mozilla-central'
make: *** [build] Error 2

I backed out bug 682832 then I was able to get a clean build.

I'm not sure if it's related, but I use these two switches --enable-gio and --disable-gnomevfs.  Also I'm building for gnome2.
(Reporter)

Updated

6 years ago
Component: General → Shell Integration
Depends on: 682832
Product: Core → Firefox
(Assignee)

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

6 years ago
G_VARIANT_TYPE_STRING_ARRAY is apparently new to glib 2.26. You're probably building against an older version of glib. I got the same problem on Debian squeeze, which comes with glib 2.24.
(Assignee)

Comment 2

6 years ago
Created attachment 584090 [details] [diff] [review]
Define G_VARIANT_TYPE_STRING_ARRAY when building against older glib

This should do the right thing.
(Assignee)

Updated

6 years ago
Assignee: nobody → mh+mozilla
(Assignee)

Updated

6 years ago
Attachment #584090 - Flags: review?(karlt)
(Assignee)

Comment 3

6 years ago
Created attachment 584536 [details] [diff] [review]
Define G_VARIANT_TYPE_STRING_ARRAY when building against older glib

Better without the spurious change in makemakefile.pm
(Assignee)

Updated

6 years ago
Attachment #584090 - Attachment is obsolete: true
Attachment #584090 - Flags: review?(karlt)
(Assignee)

Updated

6 years ago
Attachment #584536 - Flags: review?(karlt)
Attachment #584536 - Flags: review?(karlt) → review+
Blocks: 682832
No longer depends on: 682832
status-firefox11: --- → affected
tracking-firefox11: --- → ?
Keywords: regression
Blocks: 713802

Comment 4

6 years ago
Tracking due to https://bugzilla.mozilla.org/show_bug.cgi?id=713802#c3
tracking-firefox11: ? → +
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8ec9356640fd
Whiteboard: [inbound]

Comment 6

6 years ago
https://hg.mozilla.org/mozilla-central/rev/8ec9356640fd
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
(Assignee)

Comment 7

6 years ago
Comment on attachment 584536 [details] [diff] [review]
Define G_VARIANT_TYPE_STRING_ARRAY when building against older glib

[Approval Request Comment]
Regression caused by bug #682832
Firefox 11 fails to build on older Linux distros when building with --enable-gio (which, it should be noted, is not the default)
Requesting per mail request from akeybl, but i don't believe this is important enough (that is, it is probably an edge case).
Attachment #584536 - Flags: approval-mozilla-beta?

Comment 8

6 years ago
(In reply to Mike Hommey [:glandium] from comment #7)
> Firefox 11 fails to build on older Linux distros when building with
> --enable-gio (which, it should be noted, is not the default)
> Requesting per mail request from akeybl, but i don't believe this is
> important enough (that is, it is probably an edge case).

My only concern was that this would unnecessarily cause issues for Linux distros building Firefox 11 post-release. If that's not the case (and this is just an edge case), then there's no need to take on Beta 11.
tracking-firefox11: + → -

Updated

6 years ago
Attachment #584536 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.