Update Feedback addon shipped with Firefox Beta and Aurora to a working and non leaking version (1.2 or newer)

RESOLVED DUPLICATE of bug 719455

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 719455
6 years ago
6 years ago

People

(Reporter: Thomas Bertels, Unassigned)

Tracking

(Blocks: 1 bug)

9 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P2])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR:

* Install Firefox beta
* Make sure the add-on Mozilla Feedback/Test Pilot is installed and enabled or install it at https://addons.mozilla.org/en-US/firefox/addon/test-pilot/

1. Run Mem Buster Test [http://random.pavlov.net/membuster/index.html]
2. Open about:memory
3. Click <minimize memory usage>
4. Take note of the memory used

* Disable the add-on Mozilla Feedback/Test Pilot and restart from 1.
* Compare the results between the two iterations.
(Reporter)

Comment 1

6 years ago
Created attachment 582078 [details]
Membuster - light version

To reproduce it more easily, here's modified version of Mem Buster I wrote two years ago.
It only takes about 70 seconds and opens each time http://www.google.com in maximum 10 windows.

By the way, the memory benchmark and display feature doesn't work anymore, so if anyone knows why, you're welcome to tell me.
Can you spoil the ending for me and tell me what results you get?

If the add-on causes more memory to be used, that's not necessarily a bug.  Does it cause any zombie compartments?  (https://developer.mozilla.org/en/Zombie_Compartments.)
Whiteboard: [MemShrink]
(Reporter)

Comment 3

6 years ago
Here are the values for the memory usage reported under explicit:

Without any add-on:
42
43
44
45
45

With Feedback add-on:
65
93
117
142
169 (with 113 under heap-unclassified)

I pasted the about:memory page below.
The verbose version doesn't seem to be more interesting, but I saved it anyway.
There's no zombie compartment, it seems more like a memory fragmentation issue.


about:memory
------------

Main Process

Explicit Allocations
168.88 MB (100.0%) -- explicit
+--113.44 MB (67.17%) -- heap-unclassified
+---43.33 MB (25.66%) -- js
¦   +--37.83 MB (22.40%) -- compartment([System Principal], 0x3178000)
¦   ¦  +--24.83 MB (14.70%) -- gc-heap
¦   ¦  ¦  +--10.15 MB (06.01%) -- shapes
¦   ¦  ¦  +---8.74 MB (05.18%) -- objects
¦   ¦  ¦  +---4.93 MB (02.92%) -- arena-unused
¦   ¦  ¦  +---1.00 MB (00.59%) -- (6 omitted)
¦   ¦  +---5.81 MB (03.44%) -- property-tables
¦   ¦  +---3.67 MB (02.17%) -- object-slots
¦   ¦  +---2.31 MB (01.37%) -- (8 omitted)
¦   ¦  +---1.20 MB (00.71%) -- script-data
¦   +---2.98 MB (01.76%) -- gc-heap-chunk-dirty-unused
¦   +---1.33 MB (00.79%) -- (8 omitted)
¦   +---1.19 MB (00.70%) -- compartment(atoms)
¦       +--1.19 MB (00.70%) -- (3 omitted)
+----9.95 MB (05.89%) -- storage
¦    +--9.95 MB (05.89%) -- sqlite
¦       +--7.01 MB (04.15%) -- places.sqlite
¦       ¦  +--6.72 MB (03.98%) -- cache-used [4]
¦       ¦  +--0.29 MB (00.17%) -- (2 omitted)
¦       +--2.09 MB (01.24%) -- (12 omitted)
¦       +--0.85 MB (00.50%) -- other
+----1.27 MB (00.75%) -- (6 omitted)
+----0.89 MB (00.53%) -- xpti-working-set

Other Measurements
  0.00 MB -- gfx-d2d-surfacecache
  0.00 MB -- gfx-d2d-surfacevram
  0.00 MB -- gfx-surface-image
  0.18 MB -- gfx-surface-win32
138.28 MB -- heap-allocated
161.67 MB -- heap-committed
  1.63 MB -- heap-dirty
 50.72 MB -- heap-unallocated
        5 -- js-compartments-system
        1 -- js-compartments-user
 29.00 MB -- js-gc-heap
  5.16 MB -- js-gc-heap-arena-unused
  0.00 MB -- js-gc-heap-chunk-clean-unused
  2.98 MB -- js-gc-heap-chunk-dirty-unused
   28.05% -- js-gc-heap-unused-fraction
213.85 MB -- private
219.74 MB -- resident
333.87 MB -- vsize
AFAWCT Test Pilot is auto-installed on Aurora and Beta.  If that's true, then this is bad.  I'll take a look with DMD to see what the heap-unclassified is all about.
Whiteboard: [MemShrink] → [MemShrink:P1]
Thomas, I tried the attached test but it doesn't seem to work.  The page says 'The JavaScript privilege "UniversalXPConnect" is needed to get memory usage. Be sure to check the box to remember the setting for this session' but I don't know what box I'm supposed to check.  And the "Please wait..." button is greyed out, nothing seems to happen and no measurements are made.  Am I doing something wrong?

Are your results in comment 3 from the attached test?
(Reporter)

Comment 6

6 years ago
(In reply to Nicholas Nethercote [:njn] from comment #5)
> Am I doing something wrong?
netscape.security.PrivilegeManager.enablePrivilege("UniversalXPConnect") silently fails when the file calling it is not on the local filesystem.
So you just have to save it to your disk and open it to see the dialog message.

> Are your results in comment 3 from the attached test?
Yes.
I can't get this to work.  I tried a local copy and hit the "continue..." button 7 or 8 times, but I only see this:

  Memory in use at startup:	NaN
  Memory in use at test end:	
  Difference:	
  Benchmark:	0
  Result:	undefined

Is that what you mean by "the memory benchmark and display feature doesn't work anymore"?

Am I just supposed to reload about:memory after it finishes running each time?
(Reporter)

Comment 8

6 years ago
(In reply to Nicholas Nethercote [:njn] from comment #7)
> Is that what you mean by "the memory benchmark and display feature doesn't
> work anymore"?
> 
> Am I just supposed to reload about:memory after it finishes running each
> time?
Indeed.

Sorry that it wasn't clear.
I've had mixed results.  I created a new profile, installed Test Pilot, and ran your test several times, getting the following "explicit" values:  65, 180, 207, 172, 176, 178.  "heap-unclassified" was typically 80--90MB, i.e. roughly 50%, which is high.

Then I restarted the browser and tried again.  This time "explicit" stayed roughly around 80MB each time I reran.  Subsequent restarts gave similar behaviour.

Without the addon it was 60--70MB.

I re-did the "create new profile" part 3 times and the result was consistent each time.

So, apart from the first run, Test Pilot's impact is modest.

Thomas, can you replicate my results?
Whiteboard: [MemShrink:P1] → [MemShrink]
(Reporter)

Comment 10

6 years ago
(In reply to Nicholas Nethercote [:njn] from comment #9)
> So, apart from the first run, Test Pilot's impact is modest.
> 
> Thomas, can you replicate my results?

Unfortunately not. The usage stays the same no matter the number of restarts.

I just noticed that when opening the Test Pilot window, the "Current studies" tab keeps loading without displaying anything else than the loading message.
Maybe it has something to do with the memory usage. Do you see the same thing?
Whiteboard: [MemShrink] → [MemShrink:P2]
> I just noticed that when opening the Test Pilot window, the "Current
> studies" tab keeps loading without displaying anything else than the loading
> message.
> Maybe it has something to do with the memory usage. Do you see the same
> thing?

I see two entries "Firefox Beta User Background Survey" and "Broken Extensions Survey".  Each one has some descriptive text and a "Take the Survey" button.  It doesn't change when I navigate to other pages.

So it sounds like Test Pilot might be broken for you in some way?

Comment 12

6 years ago
adding Gregg Lind to this thread.
(Reporter)

Comment 13

6 years ago
I tried it again with the latest beta, and I got the same results.

But I've noticed there's a new version (1.2) than the one shipped with Firefox 10 Beta 4 (1.1.2).
This new version works correctly (the current studies show up in the window) and there's no memory usage problem anymore.

So I suggest to just update the version shipped with Firefox Beta and Aurora.
> This new version works correctly (the current studies show up in the window) and there's no memory 
> usage problem anymore.

Sounds like this is fixed!  Thanks for helping us with this, Thomas.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

6 years ago
Well, the new version 1.2 works correctly, but Firefox Beta and Aurora still ship with the old leaking and non working version 1.1.2.

Changing the bug summary according to it.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Summary: Feedback addon causes increasing memory usage → Update Feedback addon shipped with Firefox Beta and Aurora to a working and non leaking version (1.2 or newer)
Oh, well that's bad.

Jinghua, Greg, what's the story with this?

Comment 17

6 years ago
We did some investigation on it in last weeks. We found that patches are reviewed and accepted since last summer, but somehow they are not landed. 

~3M users are on TP 1.2 now, and they got it through AMO update, not FX central. 

Gregg, any new update on next steps? What did Mossop say?
(In reply to Jinghua zhang from comment #17)
> We did some investigation on it in last weeks. We found that patches are
> reviewed and accepted since last summer, but somehow they are not landed. 

Reviewed but not landed in mozilla-central? Are there bugs on file for these?

> ~3M users are on TP 1.2 now, and they got it through AMO update, not FX
> central. 
> 
> Gregg, any new update on next steps? What did Mossop say?

We have bug 719455 on file to get the tree updated to 1.2, still waiting on a patch or set of patches necessary to update to 1.2
> ~3M users are on TP 1.2 now, and they got it through AMO update, not FX central. 

How many people are on the older version?
Anyway, sounds like we should dupe this bug to bug 719455.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 719455
You need to log in before you can comment on or make changes to this bug.