Closed Bug 711102 Opened 8 years ago Closed 8 years ago

Weird mozlog import issue on build slave environment

Categories

(Testing :: Mozbase, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla11

People

(Reporter: ahal, Assigned: ahal)

References

Details

Attachments

(1 file)

See: https://bugzilla.mozilla.org/show_bug.cgi?id=700415#c32

Aki was seeing some weird import issue, where running "from logging import *" didn't have the setLoggerClass, getLoggerClass or addLevelName functions in it (note I can't reproduce this locally).

Apparently importing these three functions individually does work however. This is a simple fix that will need to land on m-c for bug 700415
I went ahead and committed this to master: https://github.com/mozilla/mozbase/commit/16814736319e65ff5bfc5abb21e9093f55d7f865

Patch for m-c upcoming.
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
Blocks: 700415
Comment on attachment 582027 [details] [diff] [review]
Patch 1.0 - Update mozbase including mozlog fix

Looks good.
Attachment #582027 - Flags: review?(ctalbert) → review+
https://hg.mozilla.org/mozilla-central/rev/4963f2ae7380
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla11
You need to log in before you can comment on or make changes to this bug.