Closed Bug 711198 Opened 8 years ago Closed 8 years ago

Form autocomplete should have a minimum width

Categories

(Firefox for Android :: General, defect, P2)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 12
Tracking Status
firefox11 --- verified
firefox12 --- verified
firefox13 --- verified
fennec 11+ ---

People

(Reporter: martijn.martijn, Assigned: sriram)

References

()

Details

(Keywords: testcase, uiwanted)

Attachments

(2 files, 1 obsolete file)

Attached image Screenshot
Steps to reproduce:
- Go to http://people.mozilla.org/~mwargers/tests/autocomplete_forms/textinput_small_form.html
- Tap on the input, type 'abc' and submit the form
- Tap on the input again
- Type 'a' -> form autocomplete popup appears with 'abc' in it

Expected result:
Form autcomplete popup has at least a width as big as the width of the 'abc' text (I think it should be even bigger, just a minimum width of 100px would suffice)

Actual result:
Very small autocomplete popup (see screenshot)
What is the minimum width expected here?
Keywords: uiwanted
Assignee: nobody → margaret.leibovic
Priority: -- → P2
Attached patch WIP (obsolete) — Splinter Review
This patch adds a minimum size for the autocomplete list.
This is not yet tested, as the autocomplete list is being shown (due to some regression) at the time of development.
Posting it as a placeholder to use it when main autocomplete list is being fixed.
Attachment #582990 - Flags: review?(mark.finkle)
Assignee: margaret.leibovic → sriram
Attachment #582990 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/243520b7d8c3
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Backed out on inbound and aurora:

https://hg.mozilla.org/integration/mozilla-inbound/rev/94a8078a745a
https://hg.mozilla.org/releases/mozilla-aurora/rev/9fb22061ef81
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This was discussed on IRC, but for the record, this was backed out because it broke the autocomplete popup text (the text was no longer visible).
tracking-fennec: --- → 11+
Attached patch PatchSplinter Review
This patch has been tested (unlike previous one ;)) and works fine with a minimum size of 200dpi.
Attachment #591539 - Flags: review?(mark.finkle)
Attachment #582990 - Attachment is obsolete: true
Comment on attachment 591539 [details] [diff] [review]
Patch

>+        // Late initializing variable to allow DisplayMetrics not to be null and avoid NPE
>+        if (sMinWidth == 0) {
>+            DisplayMetrics metrics = new DisplayMetrics();
>+            GeckoApp.mAppContext.getWindowManager().getDefaultDisplay().getMetrics(metrics);
>+            sMinWidth = (int) (200 * metrics.density);

Add a const for the "200"

r+ with the const
Attachment #591539 - Flags: review?(mark.finkle) → review+
The value of sMinWidth is going to set for one time for the entire run of the application. Do we want to create a variable unnecessarily to hold "200" which we won't use anywhere else at all?
https://hg.mozilla.org/mozilla-central/rev/0c26709f20dc
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Comment on attachment 591539 [details] [diff] [review]
Patch

[Approval Request Comment]
User impact if declined: 
Broken UI for autocomplete list if the text box is very small.

Testing completed (on m-c, etc.): Patch landed on 01/28

Risk to taking this patch (and alternatives if risky):
The risk is very minimal as this changes the min-width for an autocomplete popup which is shown for text-boxes with form history.
Attachment #591539 - Flags: approval-mozilla-aurora?
Attachment #591539 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #591539 - Flags: approval-mozilla-beta?
Comment on attachment 591539 [details] [diff] [review]
Patch

[Triage Comment]
Mobile only - approved for Beta 11.
Attachment #591539 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This is still reproducible on Firefox 11, reopening the bug. 

I tested using a tinderbox build: 1328530868/ 06-Feb-2012 05:30 	
Device: LG Optimus 2X (Android 2.2.2)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Andreea Pod from comment #15)
> This is still reproducible on Firefox 11, reopening the bug. 
> 
> I tested using a tinderbox build: 1328530868/ 06-Feb-2012 05:30 	
> Device: LG Optimus 2X (Android 2.2.2)

It has not landed on Firefox 11 yet. It does have approval to land on Fx11 now. We use the "status-firefox11" to update the fixed status.

Given the checkin date for m-c (Jan 28th), I think this is already landed on fx12 (Aurora).
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Verified Fixed on:
Firefox Beta 11 (20120207195459)
Firefox Aurora 12.0a2 (2012-02-07)
Firefox Nightly 13.0a1 (2012-02-08)

Device: Samsung Galaxy SII, Android 2.3.4
You need to log in before you can comment on or make changes to this bug.