Closed Bug 711232 Opened 8 years ago Closed 8 years ago

[viewport] Loading a page in a new tab shows multiple zoom animations until first screenful loads

Categories

(Firefox for Android :: General, defect, P1)

All
Android
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox11 --- verified
fennec 11+ ---

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(2 files)

1. Start Fennec, wait for about:home to load
2. Open a new tab
3. In the new tab, load some page (e.g. yahoo.com)

Observed behaviour: there is a zoom animation from the top-left corner to the full visible viewport multiple times, often interleaved with checkerboarding and general spazzing out of the display before the first screenful of content is displayed.

Expected behaviour: no spaz.
Comment on attachment 582086 [details] [diff] [review]
(1/2) Don't do unnecessary bounce animations

Review of attachment 582086 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #582086 - Flags: review?(pwalton) → review+
Comment on attachment 582087 [details] [diff] [review]
(2/2) Use a reasonable page size before document.readyState = loaded

Review of attachment 582087 [details] [diff] [review]:
-----------------------------------------------------------------

Death to 1x1. r=me
Attachment #582087 - Flags: review?(pwalton) → review+
backed out.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/e5daca9b7105
https://hg.mozilla.org/mozilla-central/rev/dcd69858c2b3
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 712423
tracking-fennec: --- → 11+
Verified fixed on Aurora: Mozilla /5.0 (Android;Linux armv7l;rv:11.0a2) Gecko/20120124 Firefox/11.0a2 Fennec/11.0a
Device: LG Optimus 2X (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.