Device rotation text zooms but doesnt restore when switching back

RESOLVED DUPLICATE of bug 707956

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 707956
7 years ago
7 years ago

People

(Reporter: tchung, Unassigned)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec11+)

Details

(Whiteboard: readability, URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 582120 [details]
portrait 1 screenshot

switching from portrait to landscape and back for web content, will automatically zoom text but not restore it back to a readable size.

Note: font inflation has been disabled for this test.

Repro:
1) launch 12-15-2011 build, Samsung Galaxy S 2
2) visit any site with text in portrait  (see URL)
3) rotate page to landscape.  notice it zooms into page in landscape mode
4) rotate back to portrait.   verify landscape zoom state is persisted.

See screenshots

Expected:
- device rotation should restore mode to whats reasonably viewable without having to zoom out

Actual:
- device rotation zooms in but does not restore state when rotating back
(Reporter)

Comment 1

7 years ago
Created attachment 582121 [details]
landscape 1 screenshot
(Reporter)

Comment 2

7 years ago
Created attachment 582122 [details]
portrait 2 screenshot

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 707956
tracking-fennec: --- → 11+
You need to log in before you can comment on or make changes to this bug.