Last Comment Bug 711478 - Windows PGO builds building without profiling data
: Windows PGO builds building without profiling data
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows 7
: -- blocker (vote)
: mozilla11
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
Mentors:
Depends on:
Blocks: 711527 696436
  Show dependency treegraph
 
Reported: 2011-12-16 08:10 PST by Ted Mielczarek [:ted.mielczarek]
Modified: 2011-12-16 10:33 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (846 bytes, patch)
2011-12-16 10:05 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
ted: review+
Details | Diff | Review

Description Ted Mielczarek [:ted.mielczarek] 2011-12-16 08:10:18 PST
bug 696436 made an inadvertent change that made us run the PGO profiling run from $(DIST)/bin instead of from $(DIST)/firefox like we're supposed to. This means that we don't actually get any of the profiling data into the optimizer.
http://hg.mozilla.org/mozilla-central/rev/6b18f5259de9#l14.12

(This broke because we expect the PGC files to wind up in $(DIST)/firefox, so we do:
rm -f ./dist/bin/*.pgc
find ./dist/firefox -name "*.pgc" -exec mv {} ./dist/bin

Ed Morley noticed this while looking at the results from bug 710712.

We need to fix that hunk of the patch.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-12-16 10:05:50 PST
Created attachment 582308 [details] [diff] [review]
patch

I just didn't realize that this was overriding the value from the included file.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-12-16 10:14:04 PST
Comment on attachment 582308 [details] [diff] [review]
patch

Review of attachment 582308 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, let's just do this.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-12-16 10:19:12 PST
Also, I totally missed this in reviewing your original patch, so this falls on me too.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-12-16 10:33:11 PST
http://hg.mozilla.org/mozilla-central/rev/3749f921ee90

Note You need to log in before you can comment on or make changes to this bug.