Closed Bug 711558 Opened 8 years ago Closed 7 years ago

email address with '+' in username not properly displayed (mozillians-dev.allizom.org)

Categories

(Participation Infrastructure :: Phonebook, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: jrgm, Unassigned)

References

Details

1) create an account on
   using an email address with a '+' in the username

2) on the profile page, the following is displayed:
     My Login Info:

     Primary Email: fred\2Bmzln@example.com
                        ^^^

Expected: Primary Email: fred+mzln@example.com

(Note: on mozillians.org (production), it appears that an email 
address with '+' in the username is not allowed.)
attempting to register with a new browserid email (non-mozilla AND mozilla domains) and a plus sign (and needing to set the password the first time) causes a 500 error on mozillians.

attempting to sign up with the same email via browserid and creating an account returns back to the create profile page and claims that there is an error with the form submission (even though all mandatory fields are filled in/checked off).
Assignee: nobody → jfong
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Version: unspecified → other
Assignee: jfong → nobody
Can't reproduce on the current site. Feel free to re-open with more information and screenshots.

Thanks!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Bumping to QA verified WFM.
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Hardware: x86 → All
See Also: → 1005613
You need to log in before you can comment on or make changes to this bug.