Status

P5
minor
VERIFIED DUPLICATE of bug 105289
18 years ago
14 years ago

People

(Reporter: galfandary, Assigned: cls)

Tracking

({embed, topembed-})

Trunk
mozilla1.0
embed, topembed-

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This would allow embeddors test thier applications without
having to actually build the package themselves.
(Assignee)

Updated

18 years ago
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 1

18 years ago
Any ideas on how to go about this?  Dumping all of dist/include sounds like a
recipe for disaster (unpublished APIs out the whazoo).
We need to label the header files as public or private and make a real export
list. It's grunt work and review work.
(Reporter)

Comment 3

18 years ago
Also include libembed_base_s.a or move the functionality therein
to one of the packaged libraries.
Summary: Include header files in nightly builds → SDK for embeddors
(Assignee)

Comment 4

18 years ago
The work may fall into the less-brain consuming tasks category but I don't think
just any grunt can do it.  By marking these headers as public/private, we'll be
defining an API. Not frozen by any means but an API nonetheless.  Perhaps
someone who's actually been following the API review meetings should be handling
this.

I'd be willing to add RELEASE_HEADERS that is adjunct to EXPORTS and will cause
the selected headers to be installed into dist/include/released or something. 

Comment 5

18 years ago
48726 - covers "freezing" api's via tokens in idl files themselves. An "SDK"
(binary dist, full docs, frozen apis) as a package, is 12+ months away. Bug,
70229 is a meta bug covering a massive TODO list for freezing apis.
http://www.mozilla.org/projects/embedding/apiReviewNotes.html covers public api
discussion.

Chris, if you'd like, I can take this bug. Everyone should note that an
embedding SDK is akin (sp?) to saying "Mozilla should release a 1.0 browser."
There's a lot more than a "SDK for embeddors" bug that comes into play (see
70229, and that's *just* the API piece - *nothing* bug api changes should be in
that meta bug). We have tons of build/dist issues to overcome.
(Reporter)

Comment 6

18 years ago
You want people to test your embedding API's. Why not help them
doing so by including the necessary resources (headers & embed lib)
in the package? This seems like 30 min. of work at the outside.
The only difference it would make is that embeddors won't have
to keep building the whole package themselves. We already
have access to all this stuff, why not save us some work?
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9 → mozilla1.0
(Reporter)

Comment 7

18 years ago
At 1.0 this would be useless to us.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 8

18 years ago
maybe for you, but not others. re-opening.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Keywords: mozilla1.0

Updated

17 years ago
Keywords: topembed

Comment 9

17 years ago
minusing to topembed- and adding embed as per edt triage.  a *very* nice to have
but not blocking a particular embedding customer.
Keywords: topembed → embed, topembed-

*** This bug has been marked as a duplicate of 105289 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Status: RESOLVED → VERIFIED

Comment 11

16 years ago
v dup.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.