Validator needs to recognize Jetpack add-ons sans components/harness.js

RESOLVED FIXED in 6.3.6

Status

addons.mozilla.org Graveyard
Add-on Validation
--
major
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: kmag, Assigned: basta)

Tracking

unspecified
6.3.6

Details

(Whiteboard: [ReviewTeam])

(Reporter)

Description

7 years ago
Jetpack 1.4 and above no longer contain a components/harness.js file. The validator needs to be updated to recognize them as such before 1.4 is released next month. The release date is 10 January, and it would be nice to have this done earlier since we always see at least a few submissions from the beta SDK.
Assignee: nobody → mattbasta
Target Milestone: 6.3.6 → 6.3.7
(Assignee)

Comment 1

7 years ago
Can we get an example Jetpack add-on to test with?
(Assignee)

Comment 4

7 years ago
Merged

https://github.com/mozilla/amo-validator/commit/3fb6e7529c9148ed671aa943c56f4567637258c3
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Applied to Zamboni in https://github.com/mozilla/zamboni/commit/8a4b5ad
Target Milestone: 6.3.7 → 6.3.6
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.