Last Comment Bug 711671 - Rename nsTelephonyWorker / nsITelephone to nsIRadioInterfaceLayer
: Rename nsTelephonyWorker / nsITelephone to nsIRadioInterfaceLayer
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla12
Assigned To: Philipp von Weitershausen [:philikon]
:
Mentors:
Depends on: 720601
Blocks: b2g-ril
  Show dependency treegraph
 
Reported: 2011-12-16 17:18 PST by Philipp von Weitershausen [:philikon]
Modified: 2012-01-23 20:29 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch, v1 (28.87 KB, patch)
2011-12-31 02:38 PST, Ben Turner (not reading bugmail, use the needinfo flag!)
no flags Details | Diff | Splinter Review
v1 (37.48 KB, patch)
2012-01-18 17:16 PST, Philipp von Weitershausen [:philikon]
no flags Details | Diff | Splinter Review
v2 (41.94 KB, patch)
2012-01-18 19:45 PST, Philipp von Weitershausen [:philikon]
bent.mozilla: review+
Details | Diff | Splinter Review

Description Philipp von Weitershausen [:philikon] 2011-12-16 17:18:09 PST
nsITelephone / nsTelephonyWorker is somewhat of a misnomer. First, it's not a worker itself, it just talks to a worker and exposes it (via nsIRadioWorker). Functionality-wise, it does more than just calls (SMS, data calls, network status -- we're in the process of adding all these now). API-wise it doesn't really provide much abstraction over the RIL, it's merely glue between the worker and the DOM.

So let's call it what it is: the RadioInterfaceLayer.
Comment 1 Philipp von Weitershausen [:philikon] 2011-12-18 12:29:37 PST
Oh, and all the RIL-stuff (nsIRadioInterfaceLayer, the RadioInterfaceLayer.js component, and ril_worker.js) should also move to from dom/telephony to dom/system/b2g IMHO (see above argument about not just being about telephony anymore).
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-12-31 02:38:11 PST
Created attachment 585122 [details] [diff] [review]
Patch, v1

Here's a stab at making this better. It's now SystemWorkerManager, since it will manage workers that are owned by system components. This also uses the GetInterface stuff that mrbkap and I have discussed in the past.

We can bikeshed more on the name later, but this is the interface we want I think. Comments and disagreements welcome (always).
Comment 3 Philipp von Weitershausen [:philikon] 2011-12-31 03:17:08 PST
Comment on attachment 585122 [details] [diff] [review]
Patch, v1

First off, having skimmed it only briefly, I agree with this patch! But this isn't quite what I had in mind for this bug. I thought the bug summary was kinda clear, but I guess it wasn't. (Way to hijack my bug, bent! :p)

I'm happy to consider this patch part 1 and do the nsITelephone -> nsIRadioInterfaceLayer renaming in part 2 (which I'm happy to write.)
Comment 4 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-12-31 09:06:28 PST
Comment on attachment 585122 [details] [diff] [review]
Patch, v1

Oops. It was late and I didn't really read the bug, was just looking for 'rename' in the summary. You're right, this isn't the bug I want.
Comment 5 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-12-31 09:07:02 PST
Moved the patch to bug 714459.
Comment 6 Philipp von Weitershausen [:philikon] 2011-12-31 10:21:10 PST
<3
Comment 7 Philipp von Weitershausen [:philikon] 2012-01-09 16:13:33 PST
Comment on attachment 585122 [details] [diff] [review]
Patch, v1

This stuff landed in the other bug.
Comment 8 Philipp von Weitershausen [:philikon] 2012-01-18 17:16:14 PST
Created attachment 589712 [details] [diff] [review]
v1

Completely mechanical rename of the interfaces and relocation of RIL-specific stuff to dom/system/b2g, as discussed in previous comments.
Comment 9 Philipp von Weitershausen [:philikon] 2012-01-18 19:45:35 PST
Created attachment 589758 [details] [diff] [review]
v2

Forgot to qrefresh... This version of the patch actually compiles ;)
Comment 10 Philipp von Weitershausen [:philikon] 2012-01-19 12:57:48 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/3bb96b5ee587
Comment 11 Ed Morley [:emorley] 2012-01-19 17:43:01 PST
https://hg.mozilla.org/mozilla-central/rev/3bb96b5ee587

Note You need to log in before you can comment on or make changes to this bug.