Rename nsTelephonyWorker / nsITelephone to nsIRadioInterfaceLayer

RESOLVED FIXED in mozilla12

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: philikon, Assigned: philikon)

Tracking

Trunk
mozilla12
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

nsITelephone / nsTelephonyWorker is somewhat of a misnomer. First, it's not a worker itself, it just talks to a worker and exposes it (via nsIRadioWorker). Functionality-wise, it does more than just calls (SMS, data calls, network status -- we're in the process of adding all these now). API-wise it doesn't really provide much abstraction over the RIL, it's merely glue between the worker and the DOM.

So let's call it what it is: the RadioInterfaceLayer.
Oh, and all the RIL-stuff (nsIRadioInterfaceLayer, the RadioInterfaceLayer.js component, and ril_worker.js) should also move to from dom/telephony to dom/system/b2g IMHO (see above argument about not just being about telephony anymore).
Created attachment 585122 [details] [diff] [review]
Patch, v1

Here's a stab at making this better. It's now SystemWorkerManager, since it will manage workers that are owned by system components. This also uses the GetInterface stuff that mrbkap and I have discussed in the past.

We can bikeshed more on the name later, but this is the interface we want I think. Comments and disagreements welcome (always).
Assignee: philipp → bent.mozilla
Status: NEW → ASSIGNED
Attachment #585122 - Flags: review?(mrbkap)
Comment on attachment 585122 [details] [diff] [review]
Patch, v1

First off, having skimmed it only briefly, I agree with this patch! But this isn't quite what I had in mind for this bug. I thought the bug summary was kinda clear, but I guess it wasn't. (Way to hijack my bug, bent! :p)

I'm happy to consider this patch part 1 and do the nsITelephone -> nsIRadioInterfaceLayer renaming in part 2 (which I'm happy to write.)
Comment on attachment 585122 [details] [diff] [review]
Patch, v1

Oops. It was late and I didn't really read the bug, was just looking for 'rename' in the summary. You're right, this isn't the bug I want.
Attachment #585122 - Flags: review?(mrbkap)
Assignee: bent.mozilla → philipp
Moved the patch to bug 714459.
<3
Comment on attachment 585122 [details] [diff] [review]
Patch, v1

This stuff landed in the other bug.
Attachment #585122 - Attachment is obsolete: true
Created attachment 589712 [details] [diff] [review]
v1

Completely mechanical rename of the interfaces and relocation of RIL-specific stuff to dom/system/b2g, as discussed in previous comments.
Attachment #589712 - Flags: review?(bent.mozilla)
Created attachment 589758 [details] [diff] [review]
v2

Forgot to qrefresh... This version of the patch actually compiles ;)
Attachment #589712 - Attachment is obsolete: true
Attachment #589712 - Flags: review?(bent.mozilla)
Attachment #589758 - Flags: review?(bent.mozilla)
Attachment #589758 - Flags: review?(bent.mozilla) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/3bb96b5ee587
https://hg.mozilla.org/mozilla-central/rev/3bb96b5ee587
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla12
(Assignee)

Updated

6 years ago
Depends on: 720601
You need to log in before you can comment on or make changes to this bug.