Add support for local installations

RESOLVED DUPLICATE of bug 545410

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED DUPLICATE of bug 545410
6 years ago
6 years ago

People

(Reporter: Alexander Karatarakis, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
This is related to e-mail notifications and the url shown in the browser.

Current behavior:
Before I set urlbase, the default /bugzilla4/ is used. This allows me to log-in and do anything from the local IP address as well as the remote IP address (they are the same machine, just different IP, one accessed locally and the other accessed from the internet). However, e-mail notifications have urls of the form:
/bugzilla4/blahblahblah
so you must manually append http://theIPhere/

If I set the urlbase to the remote IP address, then e-mails work correctly but the log-in only works for the remote IP address. I can access the site from the local IP address but I am not logged in and once I login, I am automatically redirected to the remote IP address.

For the most part, you can ignore the local IP and work with the remote IP. However, it would be a good enhancement if support was added for local installations as well. Possible idea:

- Have a local_urlbase (and local_sslbase)
- If they are set, send both local and Internet address in the e-mail notifications. The receiver can then choose to use the correct url depending on where he is at the moment(eg he might be at work->local access, or at home->remote access)
- Keep browsing on the IP the server was accessed from, instead of forcing redirect to the urlbase.

Comment 1

6 years ago
See also bug 396563, bug 491827, bug 545410.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545410
You need to log in before you can comment on or make changes to this bug.