Closed Bug 711726 Opened 10 years ago Closed 10 years ago

Race condition in service tests causing intermittent failures

Categories

(Toolkit :: Application Update, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: bbondy, Assigned: bbondy)

References

Details

Attachments

(1 file)

We currently set some environment variables that are used by the application which starts the update, then we call the application which starts the update async, then we immediately reset the env variables.  Race condition in the test.

The application which starts the update needs these env variables defined.  Sometimes they will exist, sometimes they will not exist, depending on if the app that was launched gets to them or not fast enough.

The env vars in question are: MOZ_UPDATE_ROOT_OVERRIDE and MOZ_UPDATE_APPDIR_OVERRIDE
Attached patch Patch v1.Splinter Review
Assignee: nobody → netzen
Attachment #582543 - Flags: review?(robert.bugzilla)
I think this might not be valid because I think the process gets a copy of the env variables when it starts.  I might mark this as invalid or change the subject to reflect whatever the problem is causing elm to hang on the first test. 

I'm not sure yet why the elm build is failing but the patch above doesn't seem to fix it.
Note: win debug consistently passes... 
https://tbpl.mozilla.org/?tree=Elm
I don't think this bug is valid and would very much prefer to keep this async
Attachment #582543 - Flags: review?(robert.bugzilla)
agree this is not our bug. I have a release build going now which I'll try to reproduce the problem with.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.