Last Comment Bug 711737 - Orion should support all the CSS properties from CSS1, CSS2, CSS2.1 and CSS3
: Orion should support all the CSS properties from CSS1, CSS2, CSS2.1 and CSS3
Status: RESOLVED FIXED
[sourceeditor][orion][qa-]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: 12 Branch
: x86 All
: -- normal (vote)
: Firefox 11
Assigned To: Nobody; OK to take it and work on it
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-17 11:27 PST by Paul Rouget [:paul]
Modified: 2012-02-09 15:57 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
List of missing properties (4.00 KB, patch)
2011-12-17 11:27 PST, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
patch v1 (6.79 KB, patch)
2011-12-17 11:29 PST, Paul Rouget [:paul]
mihai.sucan: review+
Details | Diff | Splinter Review
patch v1.1 (6.72 KB, patch)
2011-12-17 11:38 PST, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
patch - final (7.65 KB, patch)
2011-12-18 08:32 PST, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review

Description Paul Rouget [:paul] 2011-12-17 11:27:05 PST
Created attachment 582559 [details] [diff] [review]
List of missing properties

Some are missing. For example, "box-shadow" is not highlighted.
Comment 1 Paul Rouget [:paul] 2011-12-17 11:29:26 PST
Created attachment 582562 [details] [diff] [review]
patch v1
Comment 2 Paul Rouget [:paul] 2011-12-17 11:33:40 PST
oops, spaces vs. tabs.
Comment 3 Paul Rouget [:paul] 2011-12-17 11:38:33 PST
Created attachment 582566 [details] [diff] [review]
patch v1.1

with tabs
Comment 4 Mihai Sucan [:msucan] 2011-12-17 11:38:34 PST
Comment on attachment 582562 [details] [diff] [review]
patch v1

Review of attachment 582562 [details] [diff] [review]:
-----------------------------------------------------------------

Patch looks good. Thank you! In the same folder there's a README file that tells which Orion version is used and it lists which patches are applied on top of it. Please mention this bug as well.
Comment 5 Jean-Yves Perrier [:teoli] 2011-12-18 02:13:01 PST
While this patch may be a valid short-term solution to a specific problem, I would like to note that:

1) This is not future-proof as new CSS properties, which appear (and disappear) 3-4 times a year, will need to further, non-automatic, patching.

2) This sets the problem of the inclusion rule: what is the criteria to be eligible to be in that list. I see:
  - Experimental & Implemented CSS properties which are unlikely to be removed (animation, ...) but are still used prefixed.
  - Experimental & Implemented CSS properties that are already removed from latest drafts (box-* from the flex box model).
  - Experimental & not implemented CSS properties which may (or not) be removed in the future from the spec (like hanging-punctuation)

I don't see
  - Experimental & not implemented CSS properties which will very likely be implemented (flex-* from the new flex box model)
  - Proprietary / implemented CSS properties which are unlikely to be added to the standard (-moz-float-edge which was renamed float-displace in spec draft and removed from it later or the proprietary scrollbar-* IE properties)
  - Experimental & implemented CSS properties like user-select (implemented prefixed by IE)

and so on.

There are also non-HTML specific extension (like for SVG or EPub).

What do you think is the long-term valid solution?
Comment 6 Mihai Sucan [:msucan] 2011-12-18 02:42:31 PST
Hello Jean!

(In reply to Jean-Yves Perrier [:teoli] from comment #5)
> While this patch may be a valid short-term solution to a specific problem, I

Your concerns are valid. Thank you for taking the time to express them here.

> What do you think is the long-term valid solution?

We are aware of the problem and this is only a short-term solution such that we can get an improved experience into the developer tools of Firefox 11.

The long-term solution is being worked on upstream. The Orion team is preparing a new CSS highlighter that we hope will address most of the concerns. See:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=362337
Comment 7 Paul Rouget [:paul] 2011-12-18 08:32:20 PST
Created attachment 582674 [details] [diff] [review]
patch - final
Comment 8 Paul Rouget [:paul] 2011-12-19 07:35:38 PST
https://hg.mozilla.org/integration/fx-team/rev/582afb96bf5d
Comment 9 Tim Taubert [:ttaubert] 2011-12-20 00:59:12 PST
https://hg.mozilla.org/mozilla-central/rev/582afb96bf5d
Comment 10 Scoobidiver (away) 2011-12-21 05:14:03 PST
It missed the Firefox 11 release for 10 minutes.
Comment 11 Rob Campbell [:rc] (:robcee) 2011-12-21 05:31:28 PST
Comment on attachment 582674 [details] [diff] [review]
patch - final

missing CSS properties in our source editor. Minor impact, but a good bit of polish. Low-risk.
Comment 12 Scoobidiver (away) 2011-12-21 05:42:42 PST
May be I am wrong about the Firefox 11 target because this changeset is between:
* The latest changeset in 11.0a1/20111220: http://hg.mozilla.org/mozilla-central/rev/2afd7ae68e8b.
* The first changeset in 11.0a2/20111220: http://hg.mozilla.org/mozilla-central/rev/a8506ab2c654
Comment 13 Scoobidiver (away) 2011-12-21 09:41:37 PST
I was wrong about the missed Firefox 11 target.
Comment 14 christian 2011-12-21 15:59:53 PST
Comment on attachment 582674 [details] [diff] [review]
patch - final

[triage comment]
Clearing nominations as comment 13 says they are not needed (made the source uplift)

Note You need to log in before you can comment on or make changes to this bug.