Last Comment Bug 711757 - Fatal Exception: GeckoLooper Thread @ java.lang.IllegalArgumentException: width and height must be > 0
: Fatal Exception: GeckoLooper Thread @ java.lang.IllegalArgumentException: wid...
Status: VERIFIED FIXED
[native-crash]
: crash, regression, reproducible
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 critical (vote)
: Firefox 12
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
: 712568 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-17 12:47 PST by Aaron Train [:aaronmt]
Modified: 2012-01-10 13:24 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
11+


Attachments
patch (839 bytes, patch)
2011-12-19 21:29 PST, Brad Lassey [:blassey] (use needinfo?)
dougt: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-12-17 12:47:13 PST
E/AndroidRuntime( 1543): FATAL EXCEPTION: GeckoLooper Thread
E/AndroidRuntime( 1543): java.lang.IllegalArgumentException: width and height must be > 0
E/AndroidRuntime( 1543): 	at android.graphics.Bitmap.createBitmap(Bitmap.java:603)
E/AndroidRuntime( 1543): 	at android.graphics.Bitmap.createBitmap(Bitmap.java:585)
E/AndroidRuntime( 1543): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.getBitmap(GeckoSoftwareLayerClient.java:213)
E/AndroidRuntime( 1543): 	at org.mozilla.gecko.GeckoApp$SessionSnapshotRunnable.run(GeckoApp.java:614)
E/AndroidRuntime( 1543): 	at android.os.Handler.handleCallback(Handler.java:605)
E/AndroidRuntime( 1543): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/AndroidRuntime( 1543): 	at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime( 1543): 	at org.mozilla.gecko.GeckoAppShell$LooperThread.run(GeckoAppShell.java:155)
W/ActivityManager(  153):   Force finishing activity org.mozilla.fennec/.App
W/ActivityManager(  153): Activity pause timeout for ActivityRecord{41676a20 org.mozilla.fennec/.App}
I/ActivityManager(  153): Process org.mozilla.fennec (pid 1543) has died.
D/Zygote  (   80): Process 1543 exited cleanly (1)
I/WindowManager(  153): WIN DEATH: Window{415e7138 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
W/ActivityManager(  153): Force removing ActivityRecord{4159e570 org.mozilla.fennec/.CrashReporter}: app died, no saved state
I/WindowManager(  153): WIN DEATH: Window{417bbf88 org.mozilla.fennec/org.mozilla.fennec.CrashReporter paused=false}
I/WindowManager(  153): WIN DEATH: Window{41767ba8 SurfaceView paused=false}

--
Samsung Nexus S (Android 4.0.3)
20111217090244
http://hg.mozilla.org/mozilla-central/rev/d4aad9645f77
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2011-12-19 21:29:51 PST
Created attachment 583067 [details] [diff] [review]
patch
Comment 2 Doug Turner (:dougt) 2011-12-19 22:39:59 PST
Comment on attachment 583067 [details] [diff] [review]
patch

why is the buffer <=0 ?
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2011-12-20 23:33:19 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/5367244f4d73
Comment 4 Ed Morley [:emorley] 2011-12-21 04:29:29 PST
https://hg.mozilla.org/mozilla-central/rev/5367244f4d73
Comment 5 Aaron Train [:aaronmt] 2011-12-21 08:17:37 PST
Samsung Nexus S (Android 4.0.3)
20111221041234
http://hg.mozilla.org/mozilla-central/rev/d6b976e83811
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2011-12-22 11:08:46 PST
*** Bug 712568 has been marked as a duplicate of this bug. ***
Comment 7 Mike Hommey [:glandium] 2011-12-23 11:55:33 PST
I got a crash similar to the ones I reported in bug 712568 with aurora. If this is indeed the same bug, it should be fixed on aurora as well.
Comment 8 Mike Hommey [:glandium] 2011-12-23 11:56:11 PST
https://crash-stats.mozilla.com/report/index/a93192c7-6235-421e-86f6-038632111223
that's the crash i got on aurora.
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-06 23:10:20 PST
Comment on attachment 583067 [details] [diff] [review]
patch

[Approval Request Comment]
Crash fix needed on aurora
Comment 10 Alex Keybl [:akeybl] 2012-01-09 14:53:16 PST
Comment on attachment 583067 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 11 Brad Lassey [:blassey] (use needinfo?) 2012-01-10 13:24:37 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/4d85daeaac0e

Note You need to log in before you can comment on or make changes to this bug.