If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

QNX photon port requires changes to run 4x netscape plugins

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
17 years ago
6 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Trunk
x86
Neutrino
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
patch is attached to message in url. please help get this (or a derivative) 
checked in.
(Assignee)

Comment 1

17 years ago
attaching patch based on poor man's merge. *untested*
Keywords: approval, patch, review
(Assignee)

Comment 2

17 years ago
Created attachment 27015 [details] [diff] [review]
changes to mozilla/modules

Updated

17 years ago
Keywords: 4xp

Comment 3

17 years ago
Created attachment 35985 [details] [diff] [review]
In Neutrino we require the PR_LD_GROUP flag, and there are some NO_X11 defines missing for compiling

Comment 4

17 years ago
*** Bug 71179 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Depends on: 71179
(Assignee)

Comment 5

17 years ago
um... there might be a MOZ_TOOLKIT_X11 or something define.  I should remember 
since I own the blame for whatever it is... but i'm really tired.

Comment 6

17 years ago
wtc, can you review the nspr patches? Thanks.

Comment 7

17 years ago
I've reviewed this patch before in bug #71179.  My comments
are reproduced below.

I will not add the PR_LD_GROUP flag to the NSPR prlink.h API.
It is not clear whether this loading option can be implemented
cross-platform.

You have two options:
1. If it is fine for PR_LoadLibraryWithFlags() to always pass
   RTLD_GROUP to dlopen(), you can modify
   mozilla/nsprpub/pr/src/linking/prlink.c as follows:

Index: prlink.c
===================================================================
RCS file: /cvsroot/mozilla/nsprpub/pr/src/linking/prlink.c,v
retrieving revision 3.34.2.9
diff -u -r3.34.2.9 prlink.c
--- prlink.c    2001/05/22 23:31:57     3.34.2.9
+++ prlink.c    2001/05/24 20:56:40
@@ -728,7 +728,11 @@
 #ifdef HAVE_DLL
     {
 #if defined(USE_DLFCN)
+#ifdef NTO
+    int dl_flags = RTLD_GROUP;
+#else
     int dl_flags = 0;
+#endif
     void *h;
 
     if (flags & PR_LD_LAZY) {

2. In mozilla/modules/plugin/nglsrc/nsPluginsDirUnix.cpp,
   call dlopen() directly, instead of PR_LoadLibraryWithFlags(),
   on Neutrino.
(Assignee)

Comment 8

16 years ago
just do something.

Comment 9

16 years ago
..over to timeless because it looks like he's working on this...

Can you update the patches to the latest tip and let's get them reviewed by
module owners? Are these all the changes needed to run 4x style plugins on QNX?
Thanks!
Assignee: av → timeless
Keywords: approval, review
(Assignee)

Updated

13 years ago
Assignee: timeless → timeless
QA Contact: shrir → plugins

Comment 10

6 years ago
Photon is not supported any more (that I know of), and there is no NPAPI spec for it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.