Moving messages with the context menu creates empty Mail windows (may lead to crash)

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: piskozub, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I've seen twice recently a crash testing the moving of mail messages using the
rigtht click menu (testing bug 67932). Mozilla tried to open multiple (10-20)
empty windows titled Mail and crashed while moving similar number of messages
(about 20). I checked that the messages were actually moved. It happened both
times on the first operation (therefore it is not 67932 sensu stricte, but may
be related).

It happens not every time, therefore may be hard to reproduce.

Expected result: multiple mesaages moved between folders
Actual result: They were moved but Mozilla crashed.

Both crashes on recent Win32 installer trunk builds running Win98SE (latest
build 2001030605).

Comment 1

18 years ago
Reporter do you have the talkback ID for the crash?
Summary: Crash moving mail messages → Crash moving mail messages
(Reporter)

Comment 2

18 years ago
Yes. The first two crashes were in Installer builds (I mentioned that) but I
managed to reproduce the crash for the third time on the latest talback enabled
Win32 build (2001030710) under Windows ME.

The difference is this time the messages we not actually moved. Maybe because
Windows ME crashed after creating only 4 or Mail windows (that is earlier than
the Win98 crashes that managed to create about 20 windows). The error message
was: "Mozilla has caused an error in JS3250.DLL", but obviously this may be a
symptom rather than the original cause of the crash.

The talback ID is TB27426319K

Comment 3

18 years ago
not much in the talkback report:

   JS3250.DLL + 0x162ec (0x60b562ec)             JS3250.DLL + 0x227ef
(0x60b627ef)             0x033fca10             0x03411460            
0x03427730             0x0343c5e0             0x034512e0             0x03467650
            

Comment 4

18 years ago
change qa contact to myself, cc esther
QA Contact: esther → sheelar

Comment 5

18 years ago
buildid:2001030607
Did not see any crash moving messages.  Moved single and multiple messages from 
menu item as well as context menus.  
(Reporter)

Comment 6

18 years ago
Created attachment 27524 [details]
The relevant part of my prefs.js file
(Reporter)

Comment 7

18 years ago
I have a better insight about the bug now. Moving mail with the context menu
creates in my case new empty windows (one for each message moved) that vanish
when the mail is moved. If there are too many of them (while moving multiple
messages), Mozilla dies of lack of resources. This is why the talkback were so
unhelpful. I changed the summary accordingly.

As my mail settings may be important (not everybody sees the bug), I attached
the most important settings from my prefs.js file. I summarize them here: mail
window as full screen, 3 panel view, ISO-88592 character set.
Summary: Crash moving mail messages → Moving messages with the context menu creates empty Mail windows (may lead to crash)

Comment 8

18 years ago
Reporter,
Do you have talk back id for the crash if so please copy and paste it in this 
bug.
(Reporter)

Comment 9

18 years ago
The talback number is already here in my 3/7 posting. It was TB27426319K
 and Asa's comment on it was "not much in the talkback report" - see above. The
reason is the crash is most probably caused by hitting a resource limit with
that many windows being created. It will not tell you why the windows were created.

The last time it happened to me was yesterday on the 2001032112 M0.8.1 win32
installer build. The windows started to pop-up not immidiately, but 2-3 s later,
the moment I touched the scroll bar in the message pane. This may be the missing
factor that made it so far impossible to reproduce the bug.

Comment 10

18 years ago
oops! my mistake asked for the talkback report on the wrong bug.  I had two bugs
open at that same time and updated the wrong one.

Updated

18 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
On today's commercial trunk build-2001-03-28-06 I am not able to reproduce this 
problem.  Moving multiple messages does not open multiple windows for me 
at all. Changing to ISO-88592 character set did not help either in 
reproducing this bug.  Marking this bug worksforme.  Reporter,
Open a new bug when you have reproducible steps.  

Comment 12

18 years ago
verify worksforme
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.