Firefox does not render 'fi' with Museo Sans font

RESOLVED DUPLICATE of bug 697320

Status

()

Core
Layout: Text
--
major
RESOLVED DUPLICATE of bug 697320
6 years ago
6 years ago

People

(Reporter: reuben, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Not much to say, see test case source.
I see the same thing in WebKit if I enable ligatures (by adding "text-rendering:optimizeLegibility"); basic ligatures are enabled in Gecko by default.  So chances are, this is just a broken font file that provides a blank glyph for the "fi" ligature....  ccing Jonathan to confirm.
Yes, Boris is correct. The font contains OpenType rules to automatically replace "fi" (among others) by a ligature, but the ligature glyph (as well as many other glyphs not in the basic Latin-1 set) has been blanked out. This is characteristic of some webfonts from myfonts.com, due to flaws in the tools they're using. Report the problem to your font supplier and ask for a corrected version of the font.

(See also bug 697320 comment #7.)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697320
You need to log in before you can comment on or make changes to this bug.