Last Comment Bug 711929 - Full screen and loading animation issues when playing OGG videos
: Full screen and loading animation issues when playing OGG videos
Status: RESOLVED FIXED
[9RC][fixed by bug 470628]
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: 9 Branch
: x86 Windows Vista
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-19 02:13 PST by Simona B [:simonab](PTO)
Modified: 2011-12-19 15:10 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of the issue (29.97 KB, image/jpeg)
2011-12-19 02:13 PST, Simona B [:simonab](PTO)
no flags Details

Description Simona B [:simonab](PTO) 2011-12-19 02:13:32 PST
Created attachment 582770 [details]
Screenshot of the issue

Mozilla/5.0 (Windows NT 6.0; rv:9.0) Gecko/20100101 Firefox/9.0

Difficulties when exiting from the Full Screen mode on ogg videos. Full Screen mode is not exited at the first press of the Esc button and the loading animation freezes on the video after entering the normal mode.

Reproducible: always

Steps to reproduce:
1. Load the video http://videos.mozilla.org/firefox4beta/Firefox_4_beta.theora.ogv
2. Right click on the video and from the context menu select Full Screen
3. Exit Full Screen mode by pressing the Esc button

Expected results:
After pressing the Esc button the video is exited from the Full Screen mode.

Actual results:
After pressing the first time on the Esc button an "X" icon is displayed on the middle of the screen (please see the attachment). To exit the Full Screen mode you have to click once on the video and press the Esc button again.
After the Full Screen mode is exited, the loading animation freezes on the video even if the video keeps on playing.
If you right click on the video you will notice that the first 4 items of the context menu are grayed out.

Note:
Issue is reproducible on Firefox 9 RC and on the latest Aurora.
Mozilla/5.0 (Windows NT 6.0; rv:10.0a2) Gecko/20111218 Firefox/10.0a2

Issue is not reproducible on the latest trunk.
Mozilla/5.0 (Windows NT 6.0; rv:11.0a1) Gecko/20111218 Firefox/11.0a1

This is a Windows only specific issue.
Comment 1 Chris Pearce (:cpearce) 2011-12-19 13:13:10 PST
Firefox 9 is still using the old path for full-screen, not the new DOM API.

Is the listener for the ESC key press not on the window object?
Comment 2 Chris Pearce (:cpearce) 2011-12-19 13:24:10 PST
This bug exists in Firefox 4.2a1pre as well [Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110405 Firefox/4.2a1pre] so this isn't a regression we've introduced, and we won't block the release of Firefox 9 for this. The bug is fixed on trunk, so we'll wait for that to resolving fixed.
Comment 3 Chris Pearce (:cpearce) 2011-12-19 13:25:08 PST
s/The bug is fixed on trunk, so we'll wait for that to resolving fixed./The bug is fixed on trunk, so we'll wait for that fix to percolate through to release channel. Resolving fixed./
Comment 4 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-12-19 15:10:25 PST
I updated the whiteboard to say that this was fixed by bug 470628 since the patch for that bug switched usage of full screen video to use the new DOM fullscreen API which respects the ESC key.

Note You need to log in before you can comment on or make changes to this bug.