CSS: font-family defaults don't work for cursive & fantasy fonts

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
21 years ago
20 years ago

People

(Reporter: jcarpenter0524, Assigned: harishd)

Tracking

1998-07-28
All
Windows NT

Details

(URL)

(Reporter)

Description

21 years ago
When using 'class=' to call for the font-family for cursive and fantasy, the
text is defaulting to a san serif font instead.
Here is an abbreviated code for the above URL which will show this bug:

<HTML>
<HEAD>
<TITLE>CSS1 Test Suite: font-family</TITLE>

<STYLE type="text/css">

	.three 		{font-family: cursive}
	.threeplus 	{font-family: Brush Script MT}
	.four 		{font-family: fantasy}
	.fourplus	{font-family: wide latin}

</STYLE>

</HEAD>
<BODY>

  <P class="three">This sentence should be in a cursive font.
  </P>

  <P class="threeplus">This sentence should be in Brush Script MT (a cursive
font.)
  </P>

  <P class="four">This sentence should be in a fantasy font.
  </P>

  <P class="fourplus">This sentence should be in wide latin (a fantasy font.)
  </P>

</BODY>
</HTML>
(Reporter)

Comment 1

21 years ago
Updated location of URL

Comment 2

21 years ago
The same failure happens on Unix and MAC. Changed platform to All.

Comment 3

21 years ago
well, unix and mac are going to present problems, as most people don't have
those fonts installed (i know *I* don't.)

reassigning to pollmann.

Comment 4

20 years ago
Changing priority to P1...
(Assignee)

Comment 5

20 years ago
Jan could you update the URL above ASAP.  I am unable to reach it.

Updated

20 years ago
Component: CSS → XFE
Version: other → 1998-07-28
(Reporter)

Comment 6

20 years ago
Updates URL
(Reporter)

Comment 7

20 years ago
Hey, when did you ask for the URL update?  The email request just came to me
today 11/17, yet your comment is marked 9/4!  If this is correct then we have a
serious problem with the email notification.

Updated

20 years ago
Assignee: pollmann → harishd
Status: ASSIGNED → NEW

Comment 8

20 years ago
I just changed the "Version" of this bug today, which is probably what caused
you to recieve the notification (Thanks for updating the URL!)

This is a bug that was present in Gromit, but I'm not sure it it's present in
NGLayout.  Reassigning it to Harish because he is a CSS guru now. :)  It would
be interesting to see if this CSS font-family bug has been resolved in NGLayout.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

20 years ago
I don't think this bug exist in Raptor.  Janc could you please test it and close
the bug if it doesn't exist?
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

20 years ago
Marking it fixed.  Jan please verify and close the bug.  Thanx

Updated

20 years ago
QA Contact: 3847
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

20 years ago
Works!
Verified in 2/1 build
You need to log in before you can comment on or make changes to this bug.