Dual monitors: Windows state persistence always restores to primary monitor

RESOLVED WORKSFORME

Status

()

Core
XUL
P5
normal
RESOLVED WORKSFORME
17 years ago
5 years ago

People

(Reporter: ajbu, Assigned: Dan M)

Tracking

Trunk
mozilla1.4final
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Window state persistance will try to restore the window on the primary monitor, 
regardless of the monitor the window was on.
So if a browser window is maximized on the secondary monitor and closed, the 
new browser window opens maximized on the primary monitor.

Comment 1

17 years ago
->danm/p5
Assignee: trudelle → danm
Priority: -- → P5

Comment 2

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Summary: Dual monitors: Windows state persistance always restores to primary monitor → Dual monitors: Windows state persistence always restores to primary monitor
Target Milestone: --- → mozilla0.9.2

Updated

17 years ago
Target Milestone: mozilla0.9.2 → Future

Comment 3

17 years ago
*** Bug 97672 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
*** Bug 153174 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
*** Bug 163434 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 178957 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
*** Bug 133540 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
Note that bug 133540 actually has a more detailed report than this bug, if
you're looking for details.

-M

Comment 9

15 years ago
I found this also. It seemed to work ok with 1.2, but in version 1.2.1 I found
that the browser would reset into the primary display. I did notice that the
quick launch resets itself after the browser is closed, and this seems to be
reseting the broswer back to the main display. If I disable the quick launch,
then close the browser from the secondary display, the broswer will reopen again
in the secondary display like it should.

Comment 10

15 years ago
*** Bug 186181 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
OS: All, since this also is observed with Xinerama on Linux.
OS: Windows 2000 → All

Comment 12

15 years ago
*** Bug 197678 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
I am not seeing this behaviour (as specified by comment #9) on Moz 1.4. When I
maximize a window on the secondary monitor, close it, and open a new one the new
window is maximized on the secondary monitor as expected.

Can someone confirm and we can mark this as fixed?

Comment 14

15 years ago
Gecko/20030624, Matrox G550 w Powerdesk 6.72, XP Pro (latest updates). Works
like a charm.
(Assignee)

Comment 15

15 years ago
Closing on the testimony of the two previous comments.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Target Milestone: Future → mozilla1.4final

Comment 16

5 years ago
This bug has reappeared with Version 16.0 on Mac Lion 10.7.5

Comment 17

5 years ago
This problem is still present!

It doesn't work for me.  Now on Firefox 21 and Firefox always opens in the Left Hand Monitor, even if it was in the Right Hand Monitor when last Quit.

Comment 18

5 years ago
Derek,

Here's the procedure which always works for me to change the window position. It was and still is necessary because some times Firefox will not remember the monitor position correctly if, when closed, the window was maximized.

a. un-maximize the window on the secondary monitor
b. close all instances of Firefox (including the download manager)
c. open firefox, it should start as a regular window on the secondary monitor
d. move firefox to primary monitor
e. close it once again
f. open Firefox, it should start as a regular window on the main screen (if not then it's definitely a bug).
g. Maximize the window, close it again
h. Open and it'll start maximized on main screen.
You need to log in before you can comment on or make changes to this bug.