fix average daily users for infant add-ons

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Statistics
P2
normal
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: fligtar, Assigned: cvan)

Tracking

Details

(Reporter)

Description

6 years ago
https://addons.mozilla.org/en-US/firefox/addon/visual-hashing/ doesn't have any active user count displayed on its page. The stats dashboard shows it has several ADU the last few days, but the average is still 0.

I'm thinking that if we don't have 7 days worth of data, we show average daily users as 0 so new add-ons don't show any usage until after a week. Average daily users should be calculated on the last 7 days OR however many days we have if less than 7.
(Assignee)

Updated

6 years ago
Target Milestone: --- → 6.3.6
(Assignee)

Updated

6 years ago
Assignee: nobody → cvan
(Reporter)

Comment 1

6 years ago
We should fix this with the special push next week too. It's really impacting add-ons that surge in popularity soon after they're submitted, like DeSOPA and Labs add-ons.
(Assignee)

Comment 2

6 years ago
I can't reproduce this issue anymore.

For example, here is an add-on that was released on December 24, 2011:
https://addons.mozilla.org/en-US/firefox/addon/trueblock-plus/

And, as of December 29, it has 8 users:
https://addons.mozilla.org/en-US/firefox/addon/trueblock-plus/#daily-users

My hunch is that last week our cronjobs that update the ADUs were stuck in a backed-up celery queue. Feel free to reopen if you find a case where this is still happening.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.