Closed Bug 71208 Opened 24 years ago Closed 24 years ago

Outliner can't handle skin switching

Categories

(Core Graveyard :: Skinability, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9

People

(Reporter: sspitzer, Assigned: hyatt)

References

Details

Attachments

(2 files)

on the mailnews branch, if I switch skins, all the outliner cells go blank. 
(the row count sees right, and the scroll bar scrolls, but no content)

this happens from classic to modern, or modern to classic skin switches.

you might need to have the patch in bug #71206 to try this out.

this bug may have to wait we land back on the trunk, unless hyatt has a test
case on the trunk.
Outliner has no skin for Classic yet... were you switching to classic?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.8.1
seth, we haven't added support for other themes on the outliner widget yet. so
how are you testing theme switchign?? =)
there is some classic skin support, checked in by jan on 2/24.

switching from modern to modern causes the same problem.
Putting off until after landing.
Target Milestone: mozilla0.8.1 → mozilla0.9
Summary: all cells blank on the outliner, after skin switching → Outliner can't handle skin switching
*** Bug 72275 has been marked as a duplicate of this bug. ***
*** Bug 72273 has been marked as a duplicate of this bug. ***
*** Bug 71206 has been marked as a duplicate of this bug. ***
*** Bug 72673 has been marked as a duplicate of this bug. ***
OS: Linux → All
Hardware: PC → All
Attached patch Patch, take #2Splinter Review
skinability--skin switching, not themes.
Component: Themes → Skinability
*** Bug 74422 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
FIxed.
This is skin switching, not themes. Reassing to Blake.
QA Contact: pmac → blakeross
Verifying on:

2001-04-16-04 Windows 2000.
2001-04-16-04 Mac OS 9.1
2001-04-16-10 RedHat 7.0.

Content doesn't blank out as described when this bug was filed, when switching
skins.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: