Last Comment Bug 712113 - Either brace should be clickable to add new properties in the Style panel's Rule View
: Either brace should be clickable to add new properties in the Style panel's R...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Rob Campbell [:rc] (:robcee)
:
Mentors:
: 699213 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-19 13:06 PST by Jason Grlicky [:grlicky]
Modified: 2012-01-13 12:34 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
open brace editor (6.00 KB, patch)
2011-12-21 10:04 PST, Rob Campbell [:rc] (:robcee)
jwalker: review+
Details | Diff | Review
open brace editor (3.77 KB, patch)
2011-12-22 07:54 PST, Rob Campbell [:rc] (:robcee)
no flags Details | Diff | Review

Description Jason Grlicky [:grlicky] 2011-12-19 13:06:46 PST
It seems like one can only add properties by clicking on the line of the lower brace. It'd be a lot easier to be able to click on either one. Really, it would be great to be able to click on any whitespace in the style editor to add a style.

http://cl.ly/0N290t1C263g0w0p3b1D
Comment 1 Rob Campbell [:rc] (:robcee) 2011-12-21 10:04:16 PST
Created attachment 583542 [details] [diff] [review]
open brace editor
Comment 2 Paul Rouget [:paul] 2011-12-21 10:08:18 PST
(In reply to Rob Campbell [:rc] (robcee) from comment #1)
> Created attachment 583542 [details] [diff] [review]
> open brace editor

I think you forgot to remove your code from bug 694954 :)
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-12-21 10:45:01 PST
Comment on attachment 583542 [details] [diff] [review]
open brace editor

Review of attachment 583542 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/winstripe/devtools/csshtmltree.css
@@ +231,5 @@
>    padding: 2px 5px;
>  }
>  
> +.ruleview-ruleopen {
> +  padding-right: 5px;

padding-end: 5px; ?
Comment 4 Rob Campbell [:rc] (:robcee) 2011-12-21 12:38:23 PST
paul: omg!

joe: oof!

double-smackdown. I feel suitably r-minused.
Comment 5 Rob Campbell [:rc] (:robcee) 2011-12-22 07:54:32 PST
Created attachment 583800 [details] [diff] [review]
open brace editor

updated patch
Comment 6 Paul Rouget [:paul] 2011-12-22 09:18:27 PST
(In reply to Rob Campbell [:rc] (robcee) from comment #5)
> Created attachment 583800 [details] [diff] [review]
> open brace editor
> 
> updated patch

Does padding-end exist?
I think you meant -moz-padding-end.
Comment 7 Rob Campbell [:rc] (:robcee) 2011-12-22 11:12:23 PST
https://hg.mozilla.org/integration/fx-team/rev/378207d85641

(updated stylesheets to use -moz-padding-end)
Comment 8 Tim Taubert [:ttaubert] 2011-12-29 09:36:13 PST
https://hg.mozilla.org/mozilla-central/rev/378207d85641
Comment 9 Rob Campbell [:rc] (:robcee) 2012-01-13 12:34:52 PST
*** Bug 699213 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.