Status

mozilla.org
Repository Account Requests
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: drs, Assigned: jabba)

Tracking

Details

(Reporter)

Description

7 years ago
See bug 681537 and bug 703825. My MoCo account was deleted as my internship ended and now I'm getting the following error whenever I try to push to try or inbound:

hg push -f ssh://hg.mozilla.org/try/
pushing to ssh://hg.mozilla.org/try/
remote: Permission denied (publickey,gssapi-with-mic)
abort: no suitable response from remote hg!

My old email was dsherk@mozilla.com, but I have changed it on bugzilla to bugzilla@sherk.me.
Moving over to server-ops so they can change your email.
Assignee: mozillamarcia.knous → server-ops
Status: UNCONFIRMED → NEW
Ever confirmed: true
Due to permissions system in LDAP, I've created a new user (dsherk2) for you with equivalent access as your corp ldap account. A password has been sent to you.

Let me know if this doesn't work.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

7 years ago
I'm getting the same error as before. Is there anything I should have to do with my public/private key setup?
(Reporter)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

7 years ago
Could it be that your hg client needs the new username? Perhaps just adding something like this to ~/.ssh/config:

Host hg.mozilla.org
User bugzilla@sherk.me

will fix the issue (if you currently have dsherk@mozilla.com in there)
(Reporter)

Comment 5

7 years ago
Ah yeah, that fixed it. Thanks for the tip. Please close this.
(Assignee)

Updated

7 years ago
Assignee: server-ops → jdow
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.