Last Comment Bug 712175 - /delayload gkmedia.dll
: /delayload gkmedia.dll
Status: VERIFIED FIXED
[qa!][testday-20120203]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-19 16:58 PST by (dormant account)
Modified: 2012-03-22 07:58 PDT (History)
7 users (show)
khuey: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
+
verified
verified


Attachments
Patch (1.31 KB, patch)
2012-01-03 04:39 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
mh+mozilla: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description (dormant account) 2011-12-19 16:58:17 PST
This should alleviate any startup regression caused by adding more files to read
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-01-01 10:53:30 PST
I have a patch that compiles here, but since gkmedias.dll is in dependentlibs.list it gets loaded explicitly anyways.  Does gkmedias.dll really need to be in dependentlibs?
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-01-01 10:56:33 PST
If I remove gkmedias.dll from dependentlibs.list I can start up the browser without loading it with my -DELAYLOAD patch.
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-01-03 04:39:35 PST
Created attachment 585374 [details] [diff] [review]
Patch
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-01-03 04:40:23 PST
Nominating for tracking-firefox-11 because we'll want this to mitigate any startup time regression caused by the libxul crap during the 11 cycle.
Comment 5 Alex Keybl [:akeybl] 2012-01-03 12:20:49 PST
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #4)
> Nominating for tracking-firefox-11 because we'll want this to mitigate any
> startup time regression caused by the libxul crap during the 11 cycle.

Are there bugs tracking the libxul changes and startup time regressions?

This feels to me like a possible FF11 change if it's justified by measured startup regressions, but otherwise should probably just ride the train.
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-01-05 05:50:32 PST
https://hg.mozilla.org/mozilla-central/rev/2c39af68ec8f
Comment 7 (dormant account) 2012-01-05 08:54:07 PST
Comment on attachment 585374 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): 709721
User impact if declined: slower startup than previous releases.
Testing completed (on m-c, etc.): it's landed on nightly
Risk to taking this patch (and alternatives if risky): /delayload should just work
Comment 8 Alex Keybl [:akeybl] 2012-01-06 12:42:45 PST
Comment on attachment 585374 [details] [diff] [review]
Patch

[Triage Comment]
Low risk fix to a regression in FF11. Already landed on m-c without any reported issues.

Please provide QA a testing scenario where gkmedias.dll would be utilized so that they can ensure it's properly loaded.
Comment 9 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-01-06 12:46:36 PST
The QA scenario here is simple:

1. Start the browser with a homepage like about:blank.

Verify that gkmedias.dll is not loaded (you can do this with Process Explorer).

2. Navigate to some site using html5 video (e.g. the Youtube webm trial).

Verify that gkmedias.dll is loaded and that the video works.
Comment 10 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-01-06 17:06:14 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/e5999914bab4
Comment 11 Ioana (away) 2012-02-03 08:17:23 PST
Verified as fixed using the steps in comment 9 on:
Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 12 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-01 13:44:43 PST
Removing qawanted since this has been verified fixed in Firefox 11.
Comment 13 Ioana (away) 2012-03-22 07:58:54 PDT
Verified as fixed using the steps in comment 9 on:
Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
BuildID: 20120320212821

Note You need to log in before you can comment on or make changes to this bug.