Troubleshooting Information broken due to missing aboutSupport.showWin.label string

RESOLVED FIXED in Thunderbird 11.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

({intermittent-failure, regression})

Trunk
Thunderbird 11.0
x86_64
Windows 7
intermittent-failure, regression
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Upon opening Troubleshooting Information, we see the following error:

XML Parsing Error: undefined entity
Location: file:///c:/Users/mconley/mozilla/obj-tb-tot/mozilla/dist/bin/chrome/messenger/content/messenger/about-support/aboutSupport.xhtml
Line Number 144, Column 19:                  &aboutSupport.showWin.label;
------------------^

This looks like fallout from bug 413521, and is causing Mozmill test failures in content-tabs/test-about-support.js.

This bug seems to affect both Windows and Linux.  OSX is not affected.
(Assignee)

Updated

6 years ago
Whiteboard: [tb-orange]
(Assignee)

Updated

6 years ago
Blocks: 413521
Right, that shouldn't have crept in, heh.

Comment 2

6 years ago
Sorry about that, my fault. It is an unintended incomplete change that sneaked in patch for bug 413521.
(Assignee)

Comment 3

6 years ago
Created attachment 583173 [details] [diff] [review]
Revert change to aboutSupport.xhtml

This patch reverts the change to aboutSupport.xhtml from bug 413521.

Tested locally on Windows.  This fixes Troubleshooting Information, and the test-about-support.js Mozmill test now passes.
Assignee: nobody → mconley
Attachment #583173 - Flags: review?(sagarwal)
Attachment #583173 - Flags: review?(sagarwal) → review+

Comment 4

6 years ago
Yes, revert that change to aboutSupport.xhtml, please.

Could you please help me how to use hg mq to make one patch containing changes in /mail (comm-central) simultaneously with changes to /mozilla (mozilla-central) ? It seems it is handling those tree separately and creating a patch in one of them will not see changes to files in the other one.
(Assignee)

Comment 5

6 years ago
Committed to comm-central as http://hg.mozilla.org/comm-central/rev/7e6c0779450e
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 11.0
(Assignee)

Comment 6

6 years ago
aceman:

I'm not sure you can do that, because I believe Mercurial is intentionally "hands off" when it comes to nested repositories.

Your best bet, in my opinion, is to just create separate patches for both repositories.

-Mike

Comment 7

6 years ago
OK, and then attach both patches into the same bug. Thanks, I can do that.
Flags: in-testsuite-
Keywords: regression
Keywords: intermittent-failure
Whiteboard: [tb-orange]
You need to log in before you can comment on or make changes to this bug.