change layout to use NS_IMPL_NSGETMODULE so it can be combined

VERIFIED FIXED in mozilla0.9.4

Status

()

P1
normal
VERIFIED FIXED
18 years ago
8 years ago

People

(Reporter: waterson, Assigned: waterson)

Tracking

({embed, memory-footprint, topembed})

Trunk
mozilla0.9.4
embed, memory-footprint, topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-on-trunk)

Attachments

(6 attachments)

(Assignee)

Description

18 years ago
We broke layout and content into their own DLLs, but for packaging purposes, we 
probably want to be able to combine them back. To do that cleanly, we need to 
convert the hand-rolled NS_GetModule() stuff in nsLayoutModule.cpp to use the 
NS_IMPL_NSGETMODULE magic.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: embed, footprint
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 1

18 years ago
See also bug 71249.
(Assignee)

Comment 2

18 years ago
triaging with extreme prejudice
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Comment 3

18 years ago
dprice: all this work is on the STATIC_BUILD_20010418_BRANCH. You should be able 
to pick it out and land it separately, which would be ideal. Probably will need 
some cuddling over in the commercial tree, as well.
Assignee: waterson → dprice
Status: ASSIGNED → NEW
(Assignee)

Comment 4

18 years ago
Oops. Wrong bug. :-(
Assignee: dprice → waterson
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9.2 → mozilla1.0
/me looks forward to seeing waterson's implementation of module constructors for
nsGenericFactory, along with the removal of some bogus null checks :-)
(Assignee)

Comment 6

18 years ago
Needed so we can link gecko components into a DLL.
Keywords: topembed
Priority: -- → P1
Target Milestone: mozilla1.0 → mozilla0.9.4
(Assignee)

Comment 7

18 years ago
Created attachment 44623 [details] [diff] [review]
add generic module ctor, convert layout to generic module, put DLF stuff into content module
(Assignee)

Comment 8

18 years ago
Okay, step one.

- Added ctor stuff to NS_IMPL_NSGETMODULE
- Converted layout to be a generic module, removed nsLayoutDLF and
  nsLayoutFactory in the process
- Moved DLF stuff into content temporarily

Don't bother reviewing this. I'm going to whack content next and will probably
need to make more changes to the module for that.
*** Bug 87476 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

18 years ago
*** Bug 71249 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

18 years ago
Created attachment 44664 [details] [diff] [review]
convert content to be a generic module, too
(Assignee)

Comment 12

18 years ago
Created attachment 44673 [details] [diff] [review]
and htmlparser, and uconv. apply from directory above mozilla/
(Assignee)

Comment 13

18 years ago
Okay, the last patch converts all the remaining modules (content, layout,
htmlparser, uconv) into generic modules. This should make it possible to link
these modules into a meta-component. I'll need to make some build changes on Mac
to actually land this, which I'll do Monday.
Keywords: patch
(Assignee)

Comment 14

18 years ago
Note: if you want to apply the patch, do it from one directory _above_ the
mozilla/ directory. (This keeps `patch' from getting confused about makefile mods.)
(Assignee)

Comment 15

18 years ago
cc'ing...

- nhotta & ftang for mozilla/intl/uconv/src changes
- attinasi for mozilla/layout/build changes
- harishd for mozilla/htmlparser/src changes
- jst for mozilla/content/src changes

Take a look when you get a chance -- I crave your review! :-)
(Assignee)

Comment 16

18 years ago
Created attachment 44689 [details] [diff] [review]
correct NS_IMPL_NSGETMODULE() in nsParserModule.cpp
(Assignee)

Comment 17

18 years ago
The last patch should actually work for a static build. I used the wrong module
name with NS_IMPL_NSGETMODULE in htmlparser/src/nsParserModule.cpp.

Comment 18

17 years ago
Note that locale also needs fixing (see bug 93566), but has platform-specific 
module files.
(Assignee)

Comment 19

17 years ago
Created attachment 44849 [details] [diff] [review]
update for landings over the weekend
(Assignee)

Comment 20

17 years ago
Created attachment 44893 [details] [diff] [review]
make it work on windows
(Assignee)

Updated

17 years ago
Whiteboard: fixed-on-trunk
(Assignee)

Comment 22

17 years ago
checked in on the branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 23

17 years ago
Since I 'm not exactly sure how to test this, I'm marking verified based on the
last comments

Status: RESOLVED → VERIFIED
Component: Layout → General
You need to log in before you can comment on or make changes to this bug.