:first-letter rules not visible

RESOLVED DUPLICATE of bug 694019

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 694019
6 years ago
6 years ago

People

(Reporter: jsocol, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
I was looking at David Ascher's blog and tried to look at the CSS he'd applied to the :first-letter of the :first-child paragraph. While the :first-child rule shows up fine in the style inspector, I had to go to Firebug's to see the :first-letter rule.
Component: Developer Tools: Style Editor → Developer Tools: Inspector
QA Contact: developer.tools.style.editor → developer.tools.inspector
Summary: :first-child rules not visible → :first-letter rules not visible
(Reporter)

Comment 1

6 years ago
This also applies to the :first-line, :before and :after pseudo-elements, so it might be a duplicate or it may have dependencies related to pseudo-elements.

e.g. http://jsfiddle.net/reesY/3/

Comment 2

6 years ago
:first-child is a pseudo class, while :first-letter is a pseudo element. :first-letter doesn't actually exist as a DOM element, that is why it doesn't work.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 694019
You need to log in before you can comment on or make changes to this bug.