Closed Bug 712496 Opened 10 years ago Closed 10 years ago

[Mac] Favicons don't appear in the native menu binding in Firefox 9.0

Categories

(Firefox :: General, defect)

9 Branch
All
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 705516
Tracking Status
firefox8 --- unaffected
firefox9 + affected
firefox10 --- unaffected
firefox11 --- unaffected

People

(Reporter: mario_grgic, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111216140209

Steps to reproduce:

Upgraded from Firefox 8.0.1 to Firefox 9 and all favicons from Bookmarks menu are gone. Visiting the site again does not bring them back.
It looks like favicons are there in bookmarks sidebar (Cmd+b) and in the tabs, just not in the Firefox Bookmarks menu.
See https://support.mozilla.com/en-US/kb/latest-firefox-issues?s=favicons&r=0&as=s#w_my-bookmark-or-page-icons-are-gone
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Not sure how this is resolved/invalid? The link does not mention anything about favicons in the known issues section?
If you use (or have previously used) popular favicon picker add-ons, you may have other related problems with having favicons show up. You can disable the relevant add-ons and restart Firefox to see if that restores favicon behavior.
No, I never used any such extensions. I only use Adblock Plus, Firebux, Pentadactyl, TabMix Plus, Lookup in Dictionary and Web Developer. 

The icons used to show up in Firefox 8.0.1 and earlier, but disappeared immediately after update to 9.0 (I have so far updated 4 macs with completely different hardware but all OS X 10.6.8) and icons in bookmarks menu are gone on all of them (see attached screenshot).
I upgraded Firefox 8.0.1 to 9.0 on Windows 7 Enterprise 64 bit, with same set of extensions and the problem is not present there, so this seems to be Mac OS X specific.
Another thing to note is that the icons render from the bookmarks button, just not Mac OS X system menu/Bookmarks. 

I don't think it is correct to mark this as resolved/invalid. There is definitely a problem here.
Hardware: x86 → x86_64
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 701297
bug 701297 might be somewhat related to this one, it however talks about different problem. With Firefox 8.0 people started losing favicons on all platforms everywhere (not just bookmarks invoked from menu item), however re-visiting the page would re-download them. 

This bug is more specific to 9.0 (new behavior) and only on Mac OS X.
Confirmed this is also a problem on Lion 10.7.2 with Firefox 9.0 but not Firefox 8.0.1.
reopening, this seems to be a regression in the menu binding
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: regression
Resolution: DUPLICATE → ---
Summary: All favicons gone after upgrade to Firefox 9.0 → [Mac] Favicons don't appear in the native menu binding in Firefox 9.0
strange, the menu originally appears without icons, after moving through other menus, sometimes they magically reappear, not all the submenus though. And afaict, this is fixed in Nightly...
Duplicate of this bug: 712626
so for sure it's not reproducible on 8.0.1, while I could reproduce on 9b1
This bug also occurs on Firefox 9 (final) under Mac OS X 10.7.2, but didn't occur under Firefox 8.0.1 on 10.7.2.
Bug also confirmed under Firefox 9.0.1b1 under 10.7.2.
Edit: Sorry, Comment #17 should have read "Bug also confirmed under 9.0.1 candidate build 1 under 10.7.2" instead of "Bug also confirmed under 9.0.1b1 under 10.7.2"
I'm trying to get a regression range, the first bad nightly on mozilla-central seems to be on 2011-09-23, so a possible regrange may be:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8ceaedf06a57&tochange=3c8147998124

Notice though, I still have to confirm this, at first glance I don't see anything bad in that range.
ehr nevermind, I posted the wrong range!
This the range for 22 to 23 of September nightlies, now going to double test those.
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4495e1f795c2&tochange=259d1556c221
I can confirm the range, on 22 nightly the icons are there, while on 23 nightly they appear only after visiting another menu, or don't reappear at all.

setting decodeondraw to false solves the problem, so looks like a regression of bug 573583.
Blocks: 573583
Aurora is unaffected, I suspect this is just bug 705516, fixed on Aurora 10 but not in beta 9.
Hardware: x86_64 → All
Whiteboard: [qa+]
2011-12-16 still shows the bug, 2011-12-17 doesn't, this confirms bug 705516 is the right patch for this.

I'll let release-drivers decide the fate of this bug, if we don't plan to act on it on 9.0.x, we may as well dupe it to bug 705516 and just handle the issue through support (disabling image.mem.decodeondraw till Aurora 10 is out is a simple workaround).
Depends on: 705516
(In reply to Marco Bonardo [:mak] from comment #24)
> 2011-12-16 still shows the bug, 2011-12-17 doesn't, this confirms bug 705516
> is the right patch for this.
> 
> I'll let release-drivers decide the fate of this bug, if we don't plan to
> act on it on 9.0.x, we may as well dupe it to bug 705516 and just handle the
> issue through support (disabling image.mem.decodeondraw till Aurora 10 is
> out is a simple workaround).

This is nothing we should tell end users. Anyway, this is a duplicate one way or another...
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705516
Whiteboard: [qa+]
You need to log in before you can comment on or make changes to this bug.