Last Comment Bug 712528 - win64 buildbot doesn't set WIN32_REDIST_DIR
: win64 buildbot doesn't set WIN32_REDIST_DIR
Status: VERIFIED FIXED
[fixed by bug 672799] [configs]
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: x86_64 Windows Server 2008
: P3 normal (vote)
: ---
Assigned To: Makoto Kato [:m_kato] (PTO 9/22-9/25)
:
Mentors:
: 718323 (view as bug list)
Depends on: 569375 672799
Blocks: 694371 713132
  Show dependency treegraph
 
Reported: 2011-12-20 19:04 PST by Makoto Kato [:m_kato] (PTO 9/22-9/25)
Modified: 2013-08-12 21:54 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
unaffected
fixed
verified


Attachments

Description Makoto Kato [:m_kato] (PTO 9/22-9/25) 2011-12-20 19:04:45 PST
When I check build log (https://tbpl.mozilla.org/php/getParsedLog.php?id=8075007&tree=Firefox&full=1) for win64, WIN32_REDIST_DIR isn't set.

So package (ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-11.0a1.en-US.win64-x86_64.zip) has no MSVC DLLs.

Is this expected?
Comment 1 Armen Zambrano [:armenzg] (EDT/UTC-4) 2011-12-20 20:06:04 PST
I don't know.

What are the consequences?
Comment 2 Chris Cooper [:coop] 2012-01-12 13:34:23 PST
(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #1) 
> What are the consequences?

AIUI, the build will be unusable *unless* you happen to already have a Windows dev environment on your machine that contains those DLLs.

Should be a pretty simple env change to get that var added.
Comment 3 Makoto Kato [:m_kato] (PTO 9/22-9/25) 2012-01-15 16:54:26 PST
*** Bug 718323 has been marked as a duplicate of this bug. ***
Comment 4 Serge Gautherie (:sgautherie) 2012-01-15 19:44:19 PST
This is also a blocker of bug 713132: the sooner the better...
Comment 5 Serge Gautherie (:sgautherie) 2012-01-29 02:53:42 PST
(In reply to Chris Cooper [:coop] from comment #2)
> Should be a pretty simple env change to get that var added.

Ping for action.


(In reply to Serge Gautherie (:sgautherie) from comment #4)
> This is also a blocker of bug 713132: the sooner the better...

Blocking bug 713132 means we keep getting unnoticed regressions there...
Comment 6 Serge Gautherie (:sgautherie) 2012-02-13 14:36:02 PST
(In reply to Serge Gautherie (:sgautherie) from comment #5)

> Ping for action.

What is the status?

> Blocking bug 713132 means we keep getting unnoticed regressions there...

This is needed to fix Firefox (12 and) 13.
Comment 7 Armen Zambrano [:armenzg] (EDT/UTC-4) 2012-02-14 06:48:08 PST
Thanks for your interest but win64 is not a priority for product drivers.
We already bent left and right to speed up the work to have the disappointment of not being wanted after all.

It might sound repetitive but with more than a thousand bugs open for our team I can only come to say "patches welcome" (as much I would have wanted not to need to say it).
Sorry Serge but I hope you can understand that we can't fix everything.
Comment 8 Serge Gautherie (:sgautherie) 2012-03-14 10:59:05 PDT
[D'oh, I never received, or missed, your comment.]

(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #7)

> Thanks for your interest but win64 is not a priority for product drivers.

I don't actually care about win64: I care about this bug blocking (bug 713132) "fixing" all (the other) platforms (and applications) :-/

> We already bent left and right to speed up the work to have the
> disappointment of not being wanted after all.

I sympathize!

> It might sound repetitive but with more than a thousand bugs open for our
> team I can only come to say "patches welcome" (as much I would have wanted
> not to need to say it).

Well, just saying it's currently "postponed" is enough to let me know I shouldn't continue wasting my time waiting for this (P3) to happen: thanks for that.

> Sorry Serge but I hope you can understand that we can't fix everything.

Then I'll try to exclude win64 in bug 713132...
Comment 9 Makoto Kato [:m_kato] (PTO 9/22-9/25) 2012-03-14 18:01:57 PDT
Now, since firefox for Win64 swtichs to VS2010, mozconfigs/win64/vs2010-mozconfig has WIN32_REDIST_DIR environment value for VS2010.
Comment 10 Serge Gautherie (:sgautherie) 2012-03-16 10:16:17 PDT
(In reply to Makoto Kato from comment #9)
> Now, since firefox for Win64 swtichs to VS2010,
> mozconfigs/win64/vs2010-mozconfig has WIN32_REDIST_DIR environment value for
> VS2010.

Good.
Ftr, that was bug 672799.

V.Fixed per bug 713132 comment 7.
*firefox14: verified.
*firefox13: fixed by bug 672799, and would be "unaffected, doesn't seem to build win64" anyway.
*firefox12: unaffected, doesn't seem to build win64.

Note You need to log in before you can comment on or make changes to this bug.