Closed Bug 712540 (OrangeFactorCommApps) Opened 8 years ago Closed 3 years ago

Support comm-central (apps) in Orange Factor, as TopFails did

Categories

(Tree Management :: OrangeFactor, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sgautherie, Unassigned)

References

(Blocks 4 open bugs)

Details

(Keywords: regression)

(In reply to Serge Gautherie (:sgautherie) from bug 709829 comment #5)
> Last failure: "2011-09-21 09:00 SeaMonkey Linux   [1c7e6fcdc4fa]"
> Newer/Current failures are obviously missing :-(

(In reply to Jeff Hammel [:jhammel] from bug 565307 comment #15)
> topfails has been supplanted by the Orage Factor: 
> 
> - https://wiki.mozilla.org/Auto-tools/Projects/WarOnOrange
> - http://brasstacks.mozilla.com/orangefactor/

TopFails had "views" for SeaMonkey and Thunderbird, in addition to Firefox :-)
Orange Factor misses comm-central (and related comm-*) data :-(

***

I believe having all in one webapp would be best to track common issues (related to mozilla-* code).

Yet, if the solution (at least atm) is to set up a separate webapp, so be it.
Depends on: 712545
Blocks: 711937
jgriffin, what do you think?  We may as well add other products in, although I think we'd probably need to replace the "All" tree option with "All Firefox" (and optionally other "All <product>" if we add more product trees).
Blocks: 712871
(In reply to Mark Côté ( :mcote ) from comment #1)
> jgriffin, what do you think?  We may as well add other products in, although
> I think we'd probably need to replace the "All" tree option with "All
> Firefox" (and optionally other "All <product>" if we add more product trees).

The difficulty here is that OrangeFactor's primary data source is TBPL, and this isn't used for comm-central trees.  In order to add comm-central we'd need to figure out an alternate data source that would provide similar information, plus we'd have to add parsing for all the Thunderbird, SeaMonkey tests, etc.  This is likely doable but not trivial.
(In reply to Jonathan Griffin (:jgriffin) from comment #2)
> The difficulty here is that OrangeFactor's primary data source is TBPL, and
> this isn't used for comm-central trees.

Fwiw, "c-c TBPL" is at http://build.mozillamessaging.com/tinderboxpushlog/
Blocks: 716141
Blocks: 697943
Alias: OrangeFactorCommApps
Blocks: 717753
Blocks: 717868
Blocks: 717871
Blocks: 554044
Blocks: 721166
Blocks: 562626
Blocks: 725355
No longer blocks: 562626
Blocks: 725647
Blocks: 726530
Blocks: 728779
Blocks: 728790
Blocks: 725872
No longer blocks: 725872
Blocks: 730551
No longer blocks: 725647
No longer blocks: 697943, 709829, 711937, 717753, 717871, 726530
No longer blocks: 728779
No longer blocks: 730551
Blocks: 731266
No longer blocks: 728790
No longer blocks: 554044
Blocks: 739007
No longer blocks: 721166
No longer blocks: 725355
Product: Testing → Tree Management
It looks like OrangeFactor is currently reporting data from comm-*.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.