Ctrl+Tab doesn't cycle tabs anymore

RESOLVED FIXED in Thunderbird 12.0

Status

Thunderbird
Toolbars and Tabs
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: squib, Assigned: mconley)

Tracking

Trunk
Thunderbird 12.0
x86_64
Linux

Thunderbird Tracking Flags

(thunderbird11 fixed)

Details

(Whiteboard: Just some in-code documentation for add-on developers.)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
(I'm guessing this issue is related to tabs on top, but it's possible it's something else.)

On trunk, Ctrl+Tab no longer cycles through tabs and instead does the same thing as F6 (incidentally, this is what Ctrl+Tab used to do before tabs existed). We should fix this.
Strange, Ctrl+Tab works fine for me in my local build on Win7. I haven't tried the checked-in version though, just the build I used to review the patch.
Assignee: nobody → mconley
Ctrl+Tab seems to work on Ubuntu Linux using Nightly.  Trying Windows next...
Keywords: verifyme
(Reporter)

Comment 3

5 years ago
Whoops, it appears that an add-on broke things, since I haven't updated it to take into account the changes for tabs-on-top.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Created attachment 583558 [details] [diff] [review]
Some comments for future add-on developers

This sound reasonable?
Attachment #583558 - Flags: review?(squibblyflabbetydoo)
(Reporter)

Comment 5

5 years ago
Comment on attachment 583558 [details] [diff] [review]
Some comments for future add-on developers

Review of attachment 583558 [details] [diff] [review]:
-----------------------------------------------------------------

I think you want s/Do/Don't/ but other than that, it looks good.
Attachment #583558 - Flags: review?(squibblyflabbetydoo) → review+
Created attachment 583559 [details] [diff] [review]
Take 2 on that comment patch

Whoops - should really have given that a second read after writing it.  It should have been "Do NOT use overlays".  Kind of changes the whole meaning of the comment.  ;)
Attachment #583558 - Attachment is obsolete: true
Attachment #583559 - Flags: review?(squibblyflabbetydoo)
(Reporter)

Comment 7

5 years ago
Comment on attachment 583559 [details] [diff] [review]
Take 2 on that comment patch

Pulling forward r+.
Attachment #583559 - Flags: review?(squibblyflabbetydoo) → review+
tracking-thunderbird11: --- → ?
Keywords: regression, verifyme → checkin-needed
Whiteboard: Just some in-code documentation for add-on developers.
Comment on attachment 583559 [details] [diff] [review]
Take 2 on that comment patch

I guess we'll want this documentation in TB 11 as well.
Attachment #583559 - Flags: approval-comm-aurora?
(Reporter)

Comment 9

5 years ago
Reopening, since there's a patch here now.
Status: RESOLVED → REOPENED
tracking-thunderbird11: ? → ---
Resolution: INVALID → ---
Attachment 583559 [details] [diff] - checked in to comm-central as http://hg.mozilla.org/comm-central/rev/b18bc785b36d
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
tracking-thunderbird11: --- → ?
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 12.0
Keywords: checkin-needed
Attachment #583559 - Flags: approval-comm-aurora? → approval-comm-aurora+
Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/1fd00fb881ba
status-thunderbird11: --- → fixed
tracking-thunderbird11: ? → ---
You need to log in before you can comment on or make changes to this bug.