Add GPS-A support on android

RESOLVED DUPLICATE of bug 712576

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 712576
7 years ago
2 years ago

People

(Reporter: pispo1, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.12 Safari/535.11

Steps to reproduce:

Terminal: Google Samsung Galaxy Nexus with Android Sandwich

In Firefox Mobile, go to http://html5demos.com/geo.
In Native Browser, go to http://html5demos.com/geo.


Actual results:

In Firefox Mobile:
If the GPS-D (normal GPS) has acquired the minimun number of satellites (4), it works. In other case it fails.

In Native Browser: It works without the acquistion of number of satellites (without GPS-D). It is supposed that GPS-A is used.


Expected results:

The same behaviour of Native Browser is expected.

I cannot find the exact line in the code but it is related with the usage of LocationManager.GPS_PROVIDER (LocationManager.NETWORK_PROVIDER should be added).
Severity: normal → enhancement
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712576
You need to log in before you can comment on or make changes to this bug.