Crash when touching "Get me out of here" on the "This connection is Untrusted" page

RESOLVED DUPLICATE of bug 711988

Status

()

P1
critical
RESOLVED DUPLICATE of bug 711988
7 years ago
7 years ago

People

(Reporter: glandium, Assigned: blassey)

Tracking

({crash})

unspecified
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(fennec11+)

Details

(Whiteboard: [native-crash])

(Reporter)

Description

7 years ago
- Go to any page that has a self-signed certificate or a certificate that is not signed by a CA known to Fennec (I use https://buildd.debian.org).
- Touch the "Get me out of here" button.
- Crash

https://crash-stats.mozilla.com/report/index/0f9d2549-ee1c-47b5-be73-a4f782111221
(Reporter)

Updated

7 years ago
Severity: normal → critical
Keywords: crash
Whiteboard: [native-crash]
ava.lang.IllegalStateException: Couldn't read row 0, col 2 from CursorWindow. Make sure the Cursor is initialized correctly before accessing data from it.
at android.database.CursorWindow.nativeGetString(Native Method)
at android.database.CursorWindow.getString(CursorWindow.java:442)
at android.database.AbstractWindowedCursor.getString(AbstractWindowedCursor.java:51)
at android.database.CursorWrapper.getString(CursorWrapper.java:114)
at android.database.CursorWrapper.getString(CursorWrapper.java:114)
at org.mozilla.gecko.AboutHomeContent$TopSitesViewBinder.updateTitle(AboutHomeContent.java:351)
at org.mozilla.gecko.AboutHomeContent$TopSitesViewBinder.setViewValue(AboutHomeContent.java:369)
at android.widget.SimpleCursorAdapter.bindView(SimpleCursorAdapter.java:146)
at android.widget.CursorAdapter.getView
Priority: -- → P1
Might be related to some of the fixes Brad landed to AboutHome recently
Assignee: nobody → blassey.bugs
I'm not crashing with these STR. Mike, can you retest with today's build?
Is Bug 711988 a dup of this bug?
The "get me out of here" button will load "about:home", so this is likely a crash that happens during the AboutHome native display. The crash stack also agrees with this theory.

In fact, bug 711988 shows the same stack.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711988
(Assignee)

Updated

7 years ago
tracking-fennec: --- → 11+
You need to log in before you can comment on or make changes to this bug.