Creating profile named "Default" ineffective

VERIFIED DUPLICATE of bug 6592

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED DUPLICATE of bug 6592
19 years ago
2 years ago

People

(Reporter: John G. Myers, Assigned: racham)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Installed fresh build, deleted mozregistry.dat.  Started apprunner, got the
profile wizard.  Created a profile, naming it "Default".  Apprunner exited.
Started apprunner again, got the profile wizard again.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M7
(Assignee)

Comment 1

19 years ago
We are creating a profile named 'default' by default which we will get rid of
this behavior pretty soon and create a single, real profile. Also, the registry
seems to be operating in a case insensitive mode. In your case, it should have
ideally created a profile named 'Default'.
(Assignee)

Comment 2

19 years ago
Bug# 7132 is partially responsible for this behavior. Profile 'Default' should
be treated differently from the default profile 'default'. However, this whole
default behavior will be fixed soon.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
case insensitivity of the libreg routines is causing this problem. Rename
suffers from the same issue. So, I'm marking this duplicate of bug #6592 (rename
bug) and we will see how Bug #7132 will be solved to avoid side effects like
this.

*** This bug has been marked as a duplicate of 6592 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Component: Profile Manager → Profile Manager BackEnd
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.