about:addons slow to load, waiting on popcornjs.org

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: gps, Assigned: gkoberger)

Tracking

Details

(Reporter)

Description

7 years ago
This might be due to load *right now*. I opened about:addons -> Get Add-ons in Firefox 10. The loading screen sat there for many seconds (30 or 40s) before rendering anything. The status bar said it was connecting to popcornjs.org.

It certainly appears that popcornjs.org site reliability is directly impacting/blocking the rendering of the discovery pane. Is that intentional?
[15:45:04.486] GET https://popcornjs.org/code/plugins/timeline/popcorn.timeline.css [undefined 18729ms]
[15:45:04.497] GET http://popcornjs.org/code/players/soundcloud/lib/soundcloud.player.api.js [HTTP/1.1 200 OK 20669ms]

Any chance for those to either be hosted on AMO, or their loading to be defered?
We definitely don't need to block loading on Popcorn.
Assignee: nobody → gkoberger
(Assignee)

Updated

7 years ago
Duplicate of this bug: 712855
(Assignee)

Comment 4

7 years ago
Quick update. Evidently there's a "builder" I should have used, instead of the "full dev version" (which has all plugins, and loads stuff off popcorn.js). I'm working with the awesome Popcorn.js people now to get the correct popcorn.js file.

In theory, it should be as easy as swapping out the old popcorn.js file for the newer (smaller) one.
(Assignee)

Comment 5

7 years ago
https://github.com/mozilla/zamboni/commit/45a8dc

We were using the wrong version of popcorn, which was loading a CSS file + JS file + SWF file.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.