Pasted text does not match text copied from Location bar when `browser.urlbar.trimURLs` is set to `true`

UNCONFIRMED
Unassigned

Status

()

Firefox
General
UNCONFIRMED
6 years ago
5 years ago

People

(Reporter: Andreas van dem Helge, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111216140209

Steps to reproduce:

Select a partial URL from the URL bar and then copy it to clipboard


Actual results:

Firefox mangled the copy function and what ends up in the clipboard is not what was selected


Expected results:

If a user makes the effort to select some text, when the selection is copied to the clipboard only the selected text should be copied. I understand it's the firefox design philosphy to target stupid people, but would even a stupid person want to copy something besides what they selected?
> Select a partial URL from the URL bar and then copy it to clipboard

Can you be more specific?  What was the URL? Did you select text while the page
was loading? How did you select the text - mouse and/or keyboard commands?
How did you copy the text to the clipboard - keyboard or menu command?

> Firefox mangled the copy function and what ends up in the clipboard is not
> what was selected

Exactly what was copied?  I suppose you determined the clipboard contents
by pasting it somewhere?  In which application to you do the paste?

And most importantly - can you reproduce the problem in Firefox Safe Mode?
(to determine if it's a buggy add-on that's causing the problem)
http://support.mozilla.com/en-US/kb/Safe%20Mode
(Reporter)

Comment 2

6 years ago
The address bar shows (e.g.):
server02.fhu.local:81

If I select "server02.fhu.local" the contents of the clipboard become:
http://server02.fhu.local:81/

If I select "server02" the contents of the clipboard become:
http://server02


This happens when using the mouse or keyboard (shift+arrows)
(Reporter)

Comment 3

6 years ago
How can we confirm this issue? It still happens in the new weekly version of firefox.
(Reporter)

Comment 4

5 years ago
This issue was reported against Firefox 9.0 Windows. The issue persists in Firefox 10 Windows. 

Further, in Firefox 9.0.1 MacOS this issue is also present. To reproduce:

1) Visit http://www.aol.com
2) Highlight the text "www.aol.com" in the address bar and copy it
3) Paste the text somewhere: "www.aol.com" was copied, but "http://www.aol.com" is pasted.
Please see the discussion in bug 665580.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Summary: Firefox Mangles Copy + Paste → Pasted text does not match text copied from Location bar when `browser.urlbar.trimURLs` is set to `true`
Duplicate of bug: 665580
(Reporter)

Comment 6

5 years ago
This is not a duplicate of a fixed bug at best this is not a duplicate of anything and at worst this is duplicate of a different one. The issue persists and per the comments in bug 665580:

Comment 11:Dão Gottwald [:dao]  2011-06-23 04:08:25 PDT
(In reply to comment #9)
> It would be really useful if the copy behaviour matched Chrome too: If the
> first character is included in the copy selection then prepend the protocol.

Feel free to file a bug on this.

---------------------------
Comment 47:Gavin Sharp (use gavin@gavinsharp.com for email)  2011-08-09 15:25:38 PDT
The bugs related to copy/paste inconsistencies need to be fixed, absolutely. We're tracking those separately, and some of them have already been fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Updated

5 years ago
Version: 9 Branch → 16 Branch
This bug is indeed not a duplicate of a fixed bug.  However, the behavior described by this bug is intended behavior: See bug 666964.
You need to log in before you can comment on or make changes to this bug.