ftp latest-link does not point to the latest, points to nowhere instead

VERIFIED FIXED

Status

VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: GbSlack, Assigned: standard8)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111216140209

Steps to reproduce:

want to download via
ftp://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/latest



Actual results:

the latest-link points to nowhere:

 550 Failed to change directory.



Expected results:

should point to the 9.0 directory
seems to be some revitalisation of the Bug 679678 (https://bugzilla.mozilla.org/show_bug.cgi?id=679678) and of the Bug 702131 (https://bugzilla.mozilla.org/show_bug.cgi?id=702131)
seems that the automatism of creating the link is still buggy.

Comment 1

7 years ago
FTP Directory: ftp://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/

[DIRUP] Parent Directory 
[DIR]  2.0.0.24 . . . . . . . . . . . . Mar 15  2010        
[DIR]  3.0.11 . . . . . . . . . . . . . Nov 29  2010        
[DIR]  3.1.15 . . . . . . . . . . . . . Sep 27 13:33        
[DIR]  3.1.16 . . . . . . . . . . . . . Nov 03 15:51        
[DIR]  3.1.17 . . . . . . . . . . . . . Dec 13 15:08        
[DIR]  7.0.1. . . . . . . . . . . . . . Sep 30 13:15        
[DIR]  8.0. . . . . . . . . . . . . . . Nov 08 09:22        
[DIR]  9.0. . . . . . . . . . . . . . . Dec 20 21:22        
[FILE] README . . . . . . . . . . . . . Oct 04  2007    388  [DOWNLOAD]
[LINK] latest . . . . . . . . . . . . . Dec 21 13:00         [VIEW] [DOWNLOAD] -> latest-9.0
[LINK] latest-3.1 . . . . . . . . . . . Dec 20 11:46         [VIEW] [DOWNLOAD] -> 3.1.17

Yeah, the 'latest' link points to 'latest-9.0' that does not exist. It should be '9.0'.
I think there was some reorganization recently and this may have been missed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

7 years ago
Nope, pure and simple did it wrong whilst being half asleep. Fixed now, it'll take a while to propagate out to all the mirrors though.
Assignee: nobody → mbanner
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Component: General → Release Engineering
Product: Thunderbird → Mozilla Messaging
QA Contact: general → release
Resolution: --- → FIXED
Version: 8 → other

Comment 3

7 years ago
Works for me now. That was a quick fix :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.