Last Comment Bug 712910 - Use stdint for HAL
: Use stdint for HAL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Hardware Abstraction Layer (HAL) (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: :Ms2ger
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-22 04:13 PST by :Ms2ger
Modified: 2012-05-26 15:26 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (13.31 KB, patch)
2012-05-22 01:31 PDT, :Ms2ger
cjones.bugs: review+
Details | Diff | Splinter Review
Use stdint tyles in PHal.pidl too (1.13 KB, patch)
2012-05-25 23:34 PDT, Landry Breuil (:gaston)
Ms2ger: review+
Details | Diff | Splinter Review

Description :Ms2ger 2011-12-22 04:13:00 PST
We've got mozilla/StdInt.h now, so we should use it.
Comment 1 :Ms2ger 2012-05-22 01:31:36 PDT
Created attachment 625927 [details] [diff] [review]
Patch v1
Comment 3 Landry Breuil (:gaston) 2012-05-25 22:16:34 PDT
Surprise! You broke my builds :) 
http://buildbot.rhaalovely.net/builders/mozilla-central-amd64/builds/403/steps/build/logs/stdio

hal/sandbox/SandboxHal.cpp:46: error: no matching function for call to 'mozilla::hal_sandbox::PHalChild::SendVibrate(AutoInfallibleTArray<unsigned int, 8u>&, const InfallibleTArray<long long unsigned int>&, mozilla::dom::TabChild*)'
../ipc/ipdl/_ipdlheaders/mozilla/hal_sandbox/PHalChild.h:113: note: candidates are: bool mozilla::hal_sandbox::PHalChild::SendVibrate(const InfallibleTArray<unsigned int>&, const InfallibleTArray<long unsigned int>&, mozilla::dom::PBrowserChild*)

hal/sandbox/SandboxHal.cpp:56: error: no matching function for call to 'mozilla::hal_sandbox::PHalChild::SendCancelVibrate(const InfallibleTArray<long long unsigned int>&, mozilla::dom::TabChild*)'
../ipc/ipdl/_ipdlheaders/mozilla/hal_sandbox/PHalChild.h:118: note: candidates are: bool mozilla::hal_sandbox::PHalChild::SendCancelVibrate(const InfallibleTArray<long unsigned int>&, mozilla::dom::PBrowserChild*)

../ipc/ipdl/_ipdlheaders/mozilla/hal_sandbox/PHalParent.h: At global scope:
../ipc/ipdl/_ipdlheaders/mozilla/hal_sandbox/PHalParent.h:77: warning: 'virtual bool mozilla::hal_sandbox::PHalParent::RecvVibrate(const InfallibleTArray<unsigned int>&, const InfallibleTArray<long unsigned int>&, mozilla::dom::PBrowserParent*)' was hidden
hal/sandbox/SandboxHal.cpp:275: warning:   by 'virtual bool mozilla::hal_sandbox::HalParent::RecvVibrate(const InfallibleTArray<unsigned int>&, const InfallibleTArray<long long unsigned int>&, mozilla::dom::PBrowserParent*)'

../ipc/ipdl/_ipdlheaders/mozilla/hal_sandbox/PHalParent.h:81: warning: 'virtual bool mozilla::hal_sandbox::PHalParent::RecvCancelVibrate(const InfallibleTArray<long unsigned int>&, mozilla::dom::PBrowserParent*)' was hidden
hal/sandbox/SandboxHal.cpp:301: warning:   by 'virtual bool mozilla::hal_sandbox::HalParent::RecvCancelVibrate(const InfallibleTArray<long long unsigned int>&, mozilla::dom::PBrowserParent*)'

hal/sandbox/SandboxHal.cpp:601: error: cannot allocate an object of abstract type 'mozilla::hal_sandbox::HalParent'
hal/sandbox/SandboxHal.cpp:270: note:   because the following virtual functions are pure within 'mozilla::hal_sandbox::HalParent':
../ipc/ipdl/_ipdlheaders/mozilla/hal_sandbox/PHalParent.h:77: note: 	virtual bool mozilla::hal_sandbox::PHalParent::RecvVibrate(const InfallibleTArray<unsigned int>&, const InfallibleTArray<long unsigned int>&, mozilla::dom::PBrowserParent*)
../ipc/ipdl/_ipdlheaders/mozilla/hal_sandbox/PHalParent.h:81: note: 	virtual bool mozilla::hal_sandbox::PHalParent::RecvCancelVibrate(const InfallibleTArray<long unsigned int>&, mozilla::dom::PBrowserParent*)

As usual, int64 != int64_t.....
Comment 4 Landry Breuil (:gaston) 2012-05-25 22:20:14 PDT
Wild guess, it seems it breaks because sandbox/PHal.ipdl uses uint32/uint64 when declaring Vibrate & CancelVibrate.
Comment 5 Landry Breuil (:gaston) 2012-05-25 23:34:47 PDT
Created attachment 627446 [details] [diff] [review]
Use  stdint tyles in PHal.pidl too

Easy fix, still building but went through hal/ at least.
Comment 6 :Ms2ger 2012-05-25 23:36:04 PDT
Comment on attachment 627446 [details] [diff] [review]
Use  stdint tyles in PHal.pidl too

Review of attachment 627446 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry about that.
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-05-26 06:38:15 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/9ea78fb21a20
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-05-26 15:26:43 PDT
https://hg.mozilla.org/mozilla-central/rev/9ea78fb21a20

Note You need to log in before you can comment on or make changes to this bug.