Firefox 12.0a1 Crash [@ nsTypedSelection::selectFrames(nsPresContext*, nsIRange*, bool) ]

RESOLVED DUPLICATE of bug 712937

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 712937
6 years ago
6 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
Seen while looking at trunk crash stats. Crashes started showing up using the 2011122000 build. https://crash-stats.mozilla.com/report/list?signature=nsTypedSelection::selectFrames%28nsPresContext*,%20nsIRange*,%20bool%29 

Possible regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d75ebb37080e&tochange=2afd7ae68e8b. Seems to be one layout related bug in that range: Bug 672013

One comment: Browsing the Apple App Store website. Bombed!. Will work on trying to reproduce now. 

https://crash-stats.mozilla.com/report/index/a19a8859-2845-4283-9017-247492111220

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsTypedSelection::selectFrames 	layout/generic/nsSelection.cpp:4369
1 	xul.dll 	nsTypedSelection::ReplaceAnchorFocusRange 	layout/generic/nsSelection.cpp:5075
2 	xul.dll 	nsFrameSelection::AdjustForMaintainedSelection 	layout/generic/nsSelection.cpp:1634
3 	xul.dll 	nsFrameSelection::HandleClick 	layout/generic/nsSelection.cpp:1673
4 	xul.dll 	nsFrameSelection::HandleDrag 	layout/generic/nsSelection.cpp:1749
5 	xul.dll 	nsFrame::HandleDrag 	
6 	xul.dll 	nsFrame::HandleEvent 	layout/generic/nsFrame.cpp:2146
7 	xul.dll 	nsPresShellEventCB::HandleEvent 	layout/base/nsPresShell.cpp:760
8 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:393
9 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:681
10 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6442
11 	xul.dll 	PresShell::HandlePositionedEvent 	layout/base/nsPresShell.cpp:6197
12 	xul.dll 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6027
13 	xul.dll 	PresShell::HandleEvent 	
14 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1022
15 	xul.dll 	AttachedHandleEvent 	view/src/nsView.cpp:191
16 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:3597
17 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:3620
18 	xul.dll 	nsWindow::DispatchMouseEvent 	widget/src/windows/nsWindow.cpp:4051
19 	xul.dll 	nsWindow::ProcessMessage 	widget/src/windows/nsWindow.cpp:4951
20 	xul.dll 	nsWindow::WindowProcInternal 	widget/src/windows/nsWindow.cpp:4453
21 	xul.dll 	CallWindowProcCrashProtected 	xpcom/base/nsCrashOnException.cpp:65
22 	xul.dll 	nsWindow::WindowProc 	widget/src/windows/nsWindow.cpp:4395
23 	user32.dll 	InternalCallWinProc 	
24 	user32.dll 	UserCallWinProcCheckWow 	
25 	user32.dll 	DispatchMessageWorker 	
26 	user32.dll 	DispatchMessageW 	
27 	xul.dll 	nsAppShell::ProcessNextNativeEvent 	widget/src/windows/nsAppShell.cpp:344
28 	xul.dll 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:306
29 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:622
30 	nspr4.dll 	PR_Unlock 	nsprpub/pr/src/threads/combined/prulock.c:347
31 	xul.dll 	nsDocument::RetrieveRelevantHeaders 	content/base/src/nsDocument.cpp:6694
32 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
33 	xul.dll 	_SEH_epilog4 	
34 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
35 	xul.dll 	nsRangeStore::StoreRange 	editor/libeditor/base/nsSelectionState.cpp:695
36 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
37 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:258
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712937
You need to log in before you can comment on or make changes to this bug.