Last Comment Bug 712999 - Window.open doesn't work
: Window.open doesn't work
Status: VERIFIED FIXED
: testcase
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: P2 normal (vote)
: ---
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
http://people.mozilla.org/~mwargers/t...
: 713520 (view as bug list)
Depends on: 712761
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-22 09:45 PST by Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( )
Modified: 2012-01-09 10:40 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments

Description Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2011-12-22 09:45:07 PST
See url testcase.

Steps to reproduce:
- Tap on the button

Expected result:
- A new tab opens with the url http://people.mozilla.org/~mwargers/tests/autocomplete_forms/textinput_form_dynamic.html and that tab is focused

Actual result:
- A new tab is opened, but the about:blank url is shown there and that tab is not focused. Focus seems to be going to the first tab in the list.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-29 11:24:00 PST
It might be fixed with some of the latest changes to BrowserDOMWindow.openURI
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-29 12:25:35 PST
*** Bug 713520 has been marked as a duplicate of this bug. ***
Comment 3 Matt Brubeck (:mbrubeck) 2011-12-29 12:27:22 PST
This is fixed by the patch in bug 712761.  The underlying problem is that openURI does not return the contentWindow, so a new top-level window is opened which makes Fennec very confused.

Leaving this bug open and marking bug 712761 as a dependency, because the patch there has been backed out.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-01 09:18:05 PST
fixed by bug 712761
Comment 5 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-01-05 07:19:46 PST
Works fine now in current Native trunk.

Note You need to log in before you can comment on or make changes to this bug.